Bug 30391 - Missing Bundle Identifier Error - no kCFBundleVersionKey
Summary: Missing Bundle Identifier Error - no kCFBundleVersionKey
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-05-24 15:51 UTC by outekker
Modified: 2015-05-30 06:09 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description outekker 2015-05-24 15:51:07 UTC
As background: this project was building and running successfully on device with a previous Xamarin.iOS version.

Upon trying to build and upload an iOS project to a device, the following error is displayed:

Installing application bundle
bundleInfoIntoDict:781 no kCFBundleVersionKey in ***.iOS.app
MDMCopyNextDirectoryEntries:462 bundleInfoIntoDict failed
writeDictToFile:1241 open failed for ***.iOS/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/3c51054e0ca86851a92dd77bce879bc9/e83522ee543dc2ba0e88e1910718d141edc51ac9/ManifestCache.plist : No such file or directory
MDMCacheDirectoryManifest:1315 writeDictToFile failed to write to ***.iOS/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/3c51054e0ca86851a92dd77bce879bc9/e83522ee543dc2ba0e88e1910718d141edc51ac9/ManifestCache.plist : No such file or directory
error MT1006: Could not install the application '***.iOS/bin/iPhone/Debug/***.iOS.app' on the device: Missing Bundle Identifier Error.   If not,  please fill a bug report on bugzilla.xamarin.com and provide the full path to your .app (error: 0xe800004c).
The application was terminated by a signal: SIGHUP

(Some identifiers replaced with ***)
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-25 03:34:53 UTC
It looks like you have an empty bundle id in the Info.plist file.

Can you open it and verify it's set to something?
Comment 2 outekker 2015-05-25 13:12:59 UTC
CFBundleIdentifier is set to something in the Info.plist file - I'm assuming this is the key in question?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-05-26 03:23:33 UTC
No, the error message you're getting is complaining about kCFBundleVersionKey, which is the CFBundleVersion key in the Info.plist, so verify that you have that key as well.
Comment 4 outekker 2015-05-26 13:01:29 UTC
CFBundleVersion does appear in the Info.plist file; it's set to 1.0.  (kCFBundleVersionKey does not appear, but it's just an alias if I understand correctly)
Comment 5 Rolf Bjarne Kvinge [MSFT] 2015-05-27 06:43:30 UTC
That's strange.

Do you get the same error if you create a new project from a template?

If not, maybe compare the Info.plists and see if there are any differences (use a normal text editor, to make sure our plist editor isn't confused by something strange in it).
Comment 6 outekker 2015-05-30 06:09:30 UTC
Migrating the code to a new project solved the problem, as you suggested.

There was no substantial difference between the old plist and the new one though.

Thanks for the help!