Bug 30337 - Document Outline - navigation by selecting item stops working
Summary: Document Outline - navigation by selecting item stops working
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 5.9
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2015-05-22 04:38 UTC by WillG
Modified: 2015-12-19 21:10 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description WillG 2015-05-22 04:38:30 UTC
For a while eaach time I start Xamarin Studio (Mac) I can select an item in the document outline by clciking and I am then navigated to the declaration in the code window. Very useful.

The it stops working, seeming at random, after a period of 1 minute to 1 hour after launch.

I have not noticed a pattern - any particular activity on my part that triggers this.

This is with XS 5.9.1 build 3, but happened with 5.9.0 as well
Comment 1 Mike Krüger 2015-05-27 05:10:14 UTC
This part of code got almostly rewritten in 6.0.

Seems to work for me there. 

(I tried that on my current open IDE - which was open for > 1h)
Comment 2 WillG 2015-12-19 20:53:10 UTC
7 months later, 6.0 is still not released, and it's still not working, currently at 5.10.1

Are bugs in 5 not being addressed any more?
Comment 3 Mike Krüger 2015-12-19 21:08:59 UTC
Bugs in 5 are addressed - but not all of them. 6.0 was delayed more than I thought :(. 
I thought that we would release it this year - but we're polishing it more.
At least I focus 95% on the 6.0 branch :/ - I want to have the roslyn version as good as possible.

You can get a 6.0 preview here:

http://forums.xamarin.com/discussion/53121/preview-release-xamarin-studio-6-0-with-roslyn-support/p1
Comment 4 WillG 2015-12-19 21:10:33 UTC
Thanks :)