Bug 30221 - ibtool fails during build with Argument cannot be null error
Summary: ibtool fails during build with Argument cannot be null error
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: XI 8.9.x (iOS 8.3)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
: 30292 ()
Depends on:
Reported: 2015-05-19 09:06 UTC by Richard
Modified: 2015-05-21 03:29 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Richard 2015-05-19 09:06:03 UTC
The Xamarin Studio build of iOS App on Mac (SDK 8.3, Unified API, 32+64bit with Xcode 6.3.1 and Xamarin 5.9.1) fails with an error:

Error executing tool '/Applications/Xcode.app/Contents/Developer/usr/bin/ibtool': Argument cannot be null. Parameter name: unformatted (MyApp.iOS)

To get more details I tried to run in Terminal:

/Applications/Xcode.app/Contents/Developer/usr/bin/ibtool --errors --warnings --notices --output-format xml1 --minimum-deployment-target 7.0 --target-device iphone --auto-activate-custom-fonts --sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.3.sdk --compilation-directory /MyProjectPath/obj/iPhoneSimulator/Debug/ibtool /MyProjectPath/Main.storyboard

Terminal printed the plist with warnings consistent with the Xcode designer but before that it gave this error:

nwi_state: registration failed (1000000) Interface Builder Cocoa Touch Tool ***storageTaskManagerExistsWithIdentifier:withIdentifier failed: Error Domain=NSCocoaErrorDomain Code=4099 "The operation couldn’t be completed. (Cocoa error 4099.)" (The connection to service named com.apple.nsurlstorage-cache was invalidated.) {NSDebugDescription=The connection to service named com.apple.nsurlstorage-cache was invalidated.}; { NSDebugDescription = "The connection to service named com.apple.nsurlstorage-cache was invalidated."; }

After I have the output from Terminal I tried to run the build in Xamarin again and it worked. I tried to switch build configurations and branches and was able to recreate the first error, followed by the Terminal error followed by the successful build in Xamarin.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-19 09:23:41 UTC
@Jeff, this looks like some parsing code in the IBTool task is failing.
Comment 2 Jeffrey Stedfast 2015-05-20 09:48:56 UTC
This has been fixed for ~2 weeks at this point in the 8.10 branch, just need to ship a new release.
Comment 3 Rolf Bjarne Kvinge [MSFT] 2015-05-21 03:29:31 UTC
*** Bug 30292 has been marked as a duplicate of this bug. ***