Bug 30126 - MTOUCH: error MT3001: Could not AOT the assembly
Summary: MTOUCH: error MT3001: Could not AOT the assembly
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-05-15 07:32 UTC by kechis
Modified: 2016-12-08 06:43 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

xamarin app (3.47 MB, application/zip)
2015-05-15 07:32 UTC, kechis

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description kechis 2015-05-15 07:32:10 UTC
Created attachment 11212 [details]
xamarin app

I have been trying to build a solution with a sample Extension (which also i believe there is a bug since not even the sample [Extensions] works for me).

When i run the solution it throw that error and stops, not even a clue about.

Discusses here: https://forums.xamarin.com/discussion/40406/could-not-aot-the-assembly#latest

I have tried to build in command-line and I also get the same error
Comment 1 Sebastien Pouliot 2015-05-15 08:44:10 UTC
This seems to be already fixed in master but try to remove


from AppDelegate.cs / openSocketListener and IIRC that should work (and you can replace it with a manual/code lock).
Comment 2 kechis 2015-05-18 02:47:49 UTC
thank you that solve my issue, I am still locked with the appExtension, it doesn't work but i think i should create a new issue.

Thank you