Bug 30066 - Error XA5207: Please install package: 'Android Support Library' available in SDK installer
Summary: Error XA5207: Please install package: 'Android Support Library' available in ...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.9
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-14 05:13 UTC by cheansiong
Modified: 2015-06-10 03:29 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description cheansiong 2015-05-14 05:13:24 UTC
Description of Problem:
Build tries to find classes.jar and internal_impl-21.0.3.jar, etc from package folder.
A newer version Android Support Library where found when open Android SDK Manager and is upgraded to 22.1.1 now.

Error message when compilation.
C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA5207: Please install package: 'Android Support Library' available in SDK installer. Java library file <WorkingDir>\packages\Xamarin.Android.Support.v4.21.0.3.0\lib\MonoAndroid10\21.0.3\content\classes.jar doesn't exist. (XA5207)

Steps to reproduce the problem:
1. Upgrade Xamarin Studio today 14th May, while upgrading it has no response and force close installer. After that tries to revert to older Xamarin.Android and Studio.

Actual Results:
Not possible to build.

Expected Results:


How often does this happen? 
Happen today


Additional Information:
Xamarin Studio
Version 5.9 (build 431)
Installation UUID: 6dc7a7a3-0003-4d78-87c5-82816a2da23f
Runtime:
	Microsoft .NET 4.0.30319.34209
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Version: 4.12.2 (Business Edition)
Android SDK: C:\Users\cheansiong.BD\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_71
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)

Xamarin Android Player
Not Installed

Build Information
Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 17:09:09-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 1 Saurabh 2015-06-10 02:43:03 UTC
Hi Cheansiong,

I am unable to reproduce this Issue. Are you still getting this Issue with stable builds?
Comment 2 cheansiong 2015-06-10 03:29:59 UTC
I reinstall the whole installer and the problem do not occurs, but still force me to use the latest support library to build from now. Not sure how to revert to use older support library.

Thanks if you would show me.