Bug 30017 - SIGSEGV when launching debugger
Summary: SIGSEGV when launching debugger
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 5.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-05-13 03:48 UTC by Marek Safar
Modified: 2017-05-12 08:13 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Marek Safar 2015-05-13 03:48:44 UTC
This happens to be in 1 of ~50 runs

WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
WARNING [2015-05-13 09:44:52Z]: Invalid breakpoint :Mono.Debugging.Client.Breakpoint in line 60
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) MonoDevelop.MacInterop.AppleScript.OSACompile (MonoDevelop.MacInterop.ComponentInstance,MonoDevelop.MacInterop.AEDesc&,MonoDevelop.MacInterop.OsaMode,MonoDevelop.MacInterop.OsaId&) <IL 0x00030, 0xffffffff>
  at MonoDevelop.MacInterop.AppleScript.Run (bool,MonoDevelop.MacInterop.AEDesc&,string&) [0x00086] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:133
  at MonoDevelop.MacInterop.AppleScript.Run (bool,MonoDevelop.MacInterop.AEDesc&) [0x00005] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:105
  at MonoDevelop.MacInterop.AppleScript.Run (string) [0x00015] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:79
  at MonoDevelop.MacInterop.AppleScript.Run (string,object[]) [0x00008] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacInterop/AppleScript.cs:70
  at MonoDevelop.MacIntegration.MacExternalConsoleProcess.RunTerminal (string,string,string,System.Collections.Generic.IDictionary`2<string, string>,string,bool,string&,string&) [0x000e4] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacExternalConsoleProcess.cs:121
  at MonoDevelop.MacIntegration.MacExternalConsoleProcess..ctor (string,string,string,System.Collections.Generic.IDictionary`2<string, string>,string,bool) [0x0001c] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacExternalConsoleProcess.cs:88
  at MonoDevelop.MacIntegration.MacPlatformService.StartConsoleProcess (string,string,string,System.Collections.Generic.IDictionary`2<string, string>,string,bool) [0x0000a] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MacPlatform/MacPlatform.cs:569
  at MonoDevelop.Core.Execution.ProcessService.StartConsoleProcess (string,string,string,System.Collections.Generic.IDictionary`2<string, string>,MonoDevelop.Core.Execution.IConsole,System.EventHandler) [0x0011e] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.Execution/ProcessService.cs:216
  at MonoDevelop.Debugger.Soft.SoftDebuggerEngine/<CreateDebuggerStartInfo>c__AnonStorey0.<>m__0 (System.Diagnostics.ProcessStartInfo) [0x00034] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/src/addins/MonoDevelop.Debugger.Soft/MonoDevelop.Debugger.Soft/SoftDebuggerEngine.cs:90
  at Mono.Debugger.Soft.VirtualMachineManager.BeginLaunch (System.Diagnostics.ProcessStartInfo,System.AsyncCallback,Mono.Debugger.Soft.LaunchOptions) [0x00148] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/external/debugger-libs/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachineManager.cs:102
  at Mono.Debugging.Soft.SoftDebuggerSession.StartLaunching (Mono.Debugging.Soft.SoftDebuggerStartInfo) [0x001f9] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerSession.cs:210
  at Mono.Debugging.Soft.SoftDebuggerSession.OnRun (Mono.Debugging.Client.DebuggerStartInfo) [0x00031] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerSession.cs:115
  at Mono.Debugging.Client.DebuggerSession/<Run>c__AnonStorey0.<>m__0 () [0x0000e] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/external/debugger-libs/Mono.Debugging/Mono.Debugging.Client/DebuggerSession.cs:323
  at Mono.Debugging.Client.DebuggerSession.<Dispatch>m__2 (object) [0x00066] in /Users/builder/data/lanes/432/192627c3/source/monodevelop/main/external/debugger-libs/Mono.Debugging/Mono.Debugging.Client/DebuggerSession.cs:281
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void__this___object (object,intptr,intptr,intptr) <IL 0x00062, 0xffffffff>

Native stacktrace:


Debug info from gdb:

(lldb) command source -s 1 '/tmp/mono-gdb-commands.PJyUEn'
warning: (i386) /Library/Frameworks/Mono.framework/Versions/Current/lib/libglib-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libintl.8.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgtk-quartz-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgdk-quartz-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libpangocairo-1.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libpango-1.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgthread-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libatk-1.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libcairo.2.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libpixman-1.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libfontconfig.1.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libexpat.1.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libfreetype.6.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgdk_pixbuf-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libpng14.14.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgio-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgmodule-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libgobject-2.0.0.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libffi.6.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/gtk-2.0/2.10.0/engines/libxamarin.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/gtk-2.0/2.10.0/engines/libquartz.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/pango/1.8.0/modules/pango-basic-coretext.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-jpeg.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/libjpeg.8.dylib empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/gtk-2.0/2.10.0/immodules/im-quartz.so empty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/pango/1.8.0/modules/pango-arabic-lang.so ewmpty dSYM file detected, dSYM was created with an executable with no debug info.
warning: (i386) /Library/Frameworks/Mono.framework/Versions/4.0.0/lib/pango/1.8.0/modules/pango-indic-lang.so empty dSYM file detected, dSYM was created with an executable with no debug info.
Process 73092 detached
(lldb) 
=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================
Comment 1 Prashant manu 2015-08-11 04:40:12 UTC
We have tried this and unable to reproduce. Could you please provide us direction/suggestion to reproduce this issue?

Environment Info:
XS 5.9.5.7
Comment 2 Kirill Osenkov 2017-05-12 00:07:01 UTC
David, is there something we can glean from the stack traces? If you don't have any ideas feel free to resolve as not repro. Thanks!