Bug 29860 - Spaces in path are a problem for /usr/bin/nuget
Summary: Spaces in path are a problem for /usr/bin/nuget
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Matt Ward
Depends on:
Reported: 2015-05-07 16:19 UTC by dennis.doubleday
Modified: 2015-05-14 18:28 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description dennis.doubleday 2015-05-07 16:19:59 UTC
I'm not completely sure this is the right place to report this, but the shell script at /Library/Frameworks/Mono.framework/Commands/nuget (which is linked to from /usr/bin/nuget) doesn't pass arguments correctly.

The $@ at the end of the script should be enclosed in quotes so that arguments with spaces in them are passed on correctly.

For example, when I tried:

/usr/bin/nuget pack -OutputDirectory "/a/path/with/a directory with spaces in the name/packaging" ...

It fails with "Invalid arguments"

But once I changed the script to include "$@" at the end, it worked correctly.

If this is not the right place, please let me know the right place and I will report it there.
Comment 1 Alexis Christoforides 2015-05-14 18:28:58 UTC
The upgrade from nuget 2.8.1 to 2.8.5 in the Mono Mac package (mono/bockbuild@89687acd6e156e8181aa4c0cbdbcb98ed851d64c) also includes the fix to using paths with spaces. This will be included in the next release cycle.

Thank you!