Bug 29682 - Add configuration to all solution items does not do as such
Summary: Add configuration to all solution items does not do as such
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 5.9
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 5.10 (C6)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2015-05-03 09:17 UTC by Neal
Modified: 2015-06-12 12:05 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2015-05-03 09:17:59 UTC
Hello,

I want to add a new configuration "BETA|iPhone" to my project so I can set specific compiler constants.  I leave the checkmark checked to add to all solution items yet it does not appear to do so.  I don't get a BETA drop down in the top left toolbar area as a build mode and when I review solution configs or any other project there is no BETA config, it's only in the project I created the new config within.

In addition, when I create a new build config such as this I do not get ARM64 options.  I have to close and reopen the solution to then show ARM64 options so I can set ARMV7 + ARM64.

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: 25d1d6a6-72c5-479c-b704-f939b8920555
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.iOS ===

Version: 8.10.0.267 (Business Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

=== Xamarin.Android ===

Version: 5.1.0.115 (Business Edition)
Android SDK: /Users/Neal/Applications/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b25)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.0.262 (Business Edition)

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.3
Darwin iMACRH.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Atin 2015-05-06 13:10:07 UTC
Case-1: I have checked case1 and getting the same behavior, when I add new configuration in a project then the configuration only show in the same project that I have created with new config. But I am not sure is this issue or not, so I am leaving this issue as new, may be developer will look into this and do the needful. 

Case-2: When I Create new configuration in the Project it shows the ARM64 option, as shown in screencast:  http://www.screencast.com/t/RARJiHBcWxX3

Environment Info:

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.Mac ===

Version: 2.0.1.24 (Business Edition)

=== Xamarin.Android ===

Version: 5.1.0.133 (Business Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.iOS ===

Version: 8.10.0.267 (Business Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.2
Darwin Admin-Macs-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Nov 13 18:36:56 PST 2014
    root:xnu-2782.10.65~2/RELEASE_X86_64 x86_64
Comment 2 xamarin-release-manager 2015-06-12 11:35:35 UTC
Fixed in version 5.10.0.132 (master)
Comment 3 Lluis Sanchez 2015-06-12 12:05:50 UTC
ARM64 combo issue fixed in 5.10.0.133.

Atin, to reproduce the Arm64 issue you have to add the configuration directly in the project options, not the solution options.