Bug 29586 - Mono sources list breaks Synaptic Update on Ubuntu 12.04
Summary: Mono sources list breaks Synaptic Update on Ubuntu 12.04
Status: NEW
Alias: None
Product: Installers
Classification: Mono
Component: Linux packages ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Duncan Mak
Depends on:
Reported: 2015-04-30 07:34 UTC by Sergey Zhukov
Modified: 2017-05-16 21:03 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 29586 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Sergey Zhukov 2015-04-30 07:34:35 UTC
I have been used xamarin repositories in Ubuntu 12.04 32 bit for a long time without issues. But after some day (in the middle of the March) the repository became broken and I cannot update mono anymore. Moreover mono repository affects on the system packages too and I can't do security updates in my system.

The issue:
I have file /etc/apt/sources.list.d/mono-xamarin.list with the following content:

deb http://download.mono-project.com/repo/debian wheezy main
deb-src http://download.mono-project.com/repo/debian wheezy main
deb http://download.mono-project.com/repo/debian wheezy-libtiff-compat main
deb-src http://download.mono-project.com/repo/debian wheezy-libtiff-compat main

When I go to Update Manager and click on "Check" button, I've got a message: "Not all updates can be installed. Run a partial upgrade to install as many updates as possible". Some Ubuntu security updates are unchecked (and disabled) and most of the xamarin mono updates are unchecked (and disabled) too.

If I remove file /etc/apt/sources.list.d/mono-xamarin.list and then click "Check" button on "Update Manager", then all Ubuntu Security Updates become enabled and checked and can be installed. 

I tried to run apt-get clean, but it did not help.
Comment 1 Jo Shields 2015-04-30 07:50:13 UTC
What does "apt-get dist-upgrade" tell you?

A dist-upgrade rather than a simple upgrade will be required, because a number of dependencies have changed with the removal of .NET 2.0 support - a normal upgrade will refuse to remove old packages to satisfy new dependencies
Comment 2 Sergey Zhukov 2015-04-30 15:43:22 UTC
I was able to update packages with apt-get dist-upgrade, but I can't use mono-4.0 yet due its backward incompatibility with previous version (at least my .NET 4.0 sites don't work with mono-4.0). 

I tried to switch back to mono-3.12.1 (and was able to do it), but now I've got an error message when do apt-get update:

W: Conflicting distribution: http://download.mono-project.com wheezy/snapshots/3.12.0 Release (expected wheezy/snapshots but got wheezy)

cat /etc/apt/sources.list.d/mono-xamarin.list

deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.12.0 main
deb http://download.mono-project.com/repo/debian wheezy-libtiff-compat main

I also tried to add /snapshots/3.12.0 to wheezy-libtiff-compat but apt-get update couldn't find the URL.