Bug 29333 - X.A. 5.1 profiling only works for some minimum/target APIs combination
Summary: X.A. 5.1 profiling only works for some minimum/target APIs combination
Status: RESOLVED DUPLICATE of bug 29170
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 5.1
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2015-04-23 04:13 UTC by Rodrigo Moya
Modified: 2015-04-23 12:04 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rodrigo Moya 2015-04-23 04:13:08 UTC
Profiling Xamarin Store app (https://github.com/xamarin/xamarin-store-app) wasn't working for me when profiling it with Xamarin.Android 5.1, but I just tested with another app (the one in https://bugzilla.xamarin.com/show_bug.cgi?id=28233#c0) and this one worked. So, looking at the differences, the non-working one had:

* minimum android version = API15
* target android version = API21

while the working one had API19/API19. So, changed the non-working one to 19/19 and profiling works now. So, seems it doesn't like the API15 as minimum version, or the API21 as target version (running on an API19 emulator)?
Comment 1 Rodrigo Moya 2015-04-23 10:14:22 UTC
logcat -> https://gist.github.com/rodrmoya/a674fbc83e4a7cd8ac9a
Comment 2 Rodrigo Kumpera 2015-04-23 10:55:35 UTC
Hey Alex,

It's a crash on the tools thread attach code, it looks like the thing you fixed before.
Comment 3 Rodrigo Moya 2015-04-23 12:04:07 UTC

*** This bug has been marked as a duplicate of bug 29170 ***