Bug 29322 - Certificate installation error on mono 4.1.0
Summary: Certificate installation error on mono 4.1.0
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: other ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Martin Baulig
Depends on:
Reported: 2015-04-22 13:37 UTC by Suhas
Modified: 2017-04-04 13:42 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Error screenshot (51.84 KB, image/png)
2015-04-22 13:37 UTC, Suhas

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 29322 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Suhas 2015-04-22 13:37:50 UTC
Created attachment 10869 [details]
Error screenshot

I want to run aspnet 5.0 on Linux with latest build of Mono. I was able to successfully install mono 4.1.0 from github/master. When I tried to install the certificates, I get the error as mentioned in the screenshot

In case the image is not clear the error says 

Unhandled Exception:
System.IO.IOException: The authentication or decryption has failed. ---> System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: The authentir decryption has failed.

I cannot continue installation of aspnet packages unless this is fixed and I wasn't able to get any solution from my online searches. Additional info, when i run 'sudo mozroots --import --sync' I get the error

sudo mozroots --import --sync
Mozilla Roots Importer - version
Download and import trusted root certificates from Mozilla's MXR.
Copyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD licensed.

Downloading from 'http://mxr.mozilla.org/seamonkey/source/security/nss/lib/ckfw/builtins/certdata.txt?raw=1'...
Couldn't retrieve the file using the supplied information.

Any workarounds or fixes would really help