Bug 29270 - Xamarin.Forms OpenGlView is broken (Android)
Summary: Xamarin.Forms OpenGlView is broken (Android)
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.4.2
Hardware: PC Windows
: Normal critical
Target Milestone: ---
Assignee: Rui Marinho
Depends on:
Reported: 2015-04-21 07:26 UTC by andrey.falkov
Modified: 2015-06-18 06:18 UTC (History)
10 users (show)

Tags: android openglview AC
Is this bug a regression?: ---
Last known good build:

Test Case (32.96 KB, application/zip)
2015-05-06 02:08 UTC, Dominic N [MSFT]

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description andrey.falkov 2015-04-21 07:26:53 UTC
OpenGLView.OnDisplay is never called with Xamarin.Forms (Android)

Everything worked fine with previous release: 
 <package id="Xamarin.Forms" version="" targetFramework="MonoAndroid50" />
Comment 1 sco 2015-04-27 13:04:36 UTC
Hello, I posted today on Xamarin Forums the exact same problem. I confirm it worked fine with previous versions and does not work on 1.4.2 and 1.4.3-pre
Comment 2 Robert Stubbs 2015-05-01 06:23:47 UTC
We have had the same issue on 1.4.2 on a Nexus 9. 

For Note we have also had a similar issue on a Galaxy Tab 4 KitKat where we only get partial rendering and dont get horizontal lines.

It renders fine on Jelly bean and iOS no problem.
Comment 3 Dominic N [MSFT] 2015-05-06 02:08:49 UTC
Created attachment 11081 [details]
Test Case

## Overview

There seems to be a regression with OpenGLView in Android in Xamarin.Forms between 1.4.1 and 1.4.2 which results in the OpenGLView displaying a black box instead of the proper contents. I've worked with a handful of customers experiencing this issue and have been able to reproduce personally on 1.4.2 and 1.4.3-pre2 using the following steps.

## Steps to reproduce

1. Download attached sample app
2. Restore a version of Xamarin.Forms <= 1.4.1
3. Run on Android device or simulator
4. Repeat steps 2. and 3. using the most recent version of Forms
5. Run on iOS for comparison

## Expected results

OpenGLView displays flashing colours in all systems and versions of Forms

## Actual results

OpenGLView works on iOS, but not on Android when using a X.Forms package newer than 1.4.1.

## Additional information

This was tested on a Nexus 5 (Android 4.4.2) and Nexus 4 (Android 4.4.2) simulator as well as on a physical Samsung Galaxy S5 running Android 5.0

Application output: https://gist.github.com/heiligerdankgesang/6641cc7c8ab42c5b2d7a

Logcat log: https://gist.github.com/heiligerdankgesang/4c72589db706ba50706c

## Version information

Xamarin.Forms 1.4.3-pre2

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: ee07b9c8-41e3-496f-a1ab-e8a3ed3db20f
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: c8648f0
Branch: master
Build date: 2015-04-21 12:22:24-0400

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/dominic/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.3
Darwin Dominics-MBP 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 4 Stephane Delcroix 2015-06-11 18:00:04 UTC
will be included in 1.4.3 final
Comment 5 Parmendra Kumar 2015-06-18 06:18:58 UTC
I have checked this issue with xamarin.forms. and its working
fine at my end.

Hence closing this issue.

Environment info:

Xamarin Studio: 5.9.3 (build 1)
Xamarin.Android Version: 5.1.3 (Enterprise Edition)