Bug 29111 - Modal transition style FlipHorizontal is broken in Unified API
Summary: Modal transition style FlipHorizontal is broken in Unified API
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.8.0
Hardware: Other Other
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-04-15 05:19 UTC by Herman Schoenfeld
Modified: 2015-04-16 05:36 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Solution to reproduce error (6.19 KB, application/zip)
2015-04-15 05:19 UTC, Herman Schoenfeld

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Herman Schoenfeld 2015-04-15 05:19:11 UTC
Created attachment 10767 [details]
Solution to reproduce error

When presenting a modal view controller using FlipHorizontal transition style and FormSheet presentation style, the modal view is first displayed and then animated. It should animate first, as it used to in classic api.

Provided is a demo solution to reproduce the issue. Steps to reproduce

1. Press Red Button
2. Observe how modal view is quickly presented THEN flipped. This is not correct.

I also suspect other transition styles may contain visual anomalies.

Below are my environment details.

=== Xamarin Studio ===

Version 5.8.3 (build 1)
Installation UUID: aad8e2c1-53aa-4766-af0b-57b0ba105a0e
	Mono 3.12.1 ((detached/0849ec7)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312010003

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/Developer/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: f7736a4
Build date: 2015-04-09 04:22:08-0400

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 508030001
Git revision: 6e8e725e0d689351901c2c70453bfa4ea25e293b
Build date: 2015-04-06 20:31:47-04
Xamarin addins: 051cd5f8c1b5dbfc87eaef80a74aec03f34c60a8

=== Operating System ===

Mac OS X 10.10.2
Darwin 192-168-1-3.tpgi.com.au 14.1.0 Darwin Kernel Version 14.1.0
    Thu Feb 26 19:26:47 PST 2015
    root:xnu-2782.10.73~1/RELEASE_X86_64 x86_64
Comment 1 Herman Schoenfeld 2015-04-15 05:28:30 UTC
NOTE: this is being tested on iPad Simulator and iPad devices.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-04-15 06:08:20 UTC
This is what I see: http://screencast.com/t/NhvTskVz

I also get the exact same behaviour from an equivalent Xcode app: https://github.com/rolfbjarne/bug29111, so it doesn't look like an issue in Xamarin.iOS (I tried a Classic app as well, and the behaviour is the same there too).

So can you attach your Classic project as well so I can see where the difference is?
Comment 3 Herman Schoenfeld 2015-04-15 06:14:42 UTC
Hi Rolf,

When I referred to Classic app, I meant the actual app I'm developing.

This bug, in the equivalent classic solution, also occurs, so it may be one of the other changes made in 8.8.0 or maybe iOS 8.3 API. I'm not really sure, I just know it's not supposed to look that way.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2015-04-15 07:02:52 UTC
I just tried the Xcode sample in older simulators, and there's a difference in the iOS 7.1 simulator, while the 8.1, 8.2 and 8.3 simulators all behave the same, so this looks like an iOS bug/difference in iOS 8.0+

I'm closing this since it's not an issue with Xamarin.iOS.
Comment 5 Herman Schoenfeld 2015-04-15 19:06:27 UTC
Hi Rolf,

Are you able to provide a downloadable copy of your screencast so that I can lodge this bug report with Apple?
Comment 6 Rolf Bjarne Kvinge [MSFT] 2015-04-16 05:36:58 UTC
@Herman, try this: https://www.dropbox.com/s/gb4combnazb0prm/bug29111.mov?dl=0