Bug 2904 - cant debug on device
Summary: cant debug on device
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 2.8.5
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: ---
Assignee: Rolf Bjarne Kvinge [MSFT]
Depends on:
Reported: 2012-01-15 19:28 UTC by tkandiliotis
Modified: 2012-02-09 18:20 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description tkandiliotis 2012-01-15 19:28:45 UTC
System.IO.IOException: DWP Handshake failed.
  at Mono.Debugger.Soft.Connection.Connect () [0x000f9] in /private/tmp/source/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/Connection.cs:1058 
  at Mono.Debugger.Soft.VirtualMachine.connect () [0x00000] in /private/tmp/source/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachine.cs:296 
  at Mono.Debugger.Soft.VirtualMachineManager.Connect (Mono.Debugger.Soft.Connection transport, System.IO.StreamReader standardOutput, System.IO.StreamReader standardError) [0x00022] in /private/tmp/source/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachineManager.cs:334 
  at Mono.Debugger.Soft.VirtualMachineManager.ConnectInternal (System.Net.Sockets.Socket dbg_sock, System.Net.Sockets.Socket con_sock, System.Net.IPEndPoint dbg_ep, System.Net.IPEndPoint con_ep) [0x00075] in /private/tmp/source/monodevelop/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachineManager.cs:287
Comment 1 Miguel de Icaza [MSFT] 2012-01-16 14:59:25 UTC

Do you have a way to reproduce this?

Where did you get this message? 

How often does it happen?
Comment 2 tkandiliotis 2012-01-17 06:02:55 UTC

It happens randomly enough so that I haven't figured out the exact circumstances. Usually restarting the device is enough to be able to debug again. I would say 2-3 times a day it happens
Comment 3 Jeffrey Stedfast 2012-01-19 16:18:38 UTC
I take it this is while debugging a MonoTouch app on device? Is this over WiFi or USB?

(MonoDevelop -> Preferences -> Debugger -> iPhone Debugger)

Does changing that option affect this? If so, in what way?
Comment 4 tkandiliotis 2012-01-19 16:23:11 UTC
It is through USB. i will try to switch to WIFI and get back to you

Wow you guys are quick

Miguel thanks for the retweet
Comment 5 tkandiliotis 2012-01-26 13:28:54 UTC
I have switched to WIFI and this issue has not appeared since. Also , debugging starts a lot faster after I click RUN.

Before switching to WIFI, I had noticed the following :

-One sure way to start debugging successfully on the device, was to reboot both the MAC and the device
-After starting the debugging, if I clicked the red X button on MonoDevelop, the next time I tried to debug, I got this message once (DWP Handshake failed). 
-If I tried to debug again, the device would start the application normally but MonoDevelop would still say "start the app on the device" . Then I would have to reboot both MAC and device again
-When I would end the debugging by closing the app on the device (instead of clicking STOP on monoDevelop) I would be able to debug the next time as well.

Hope this helps
Comment 6 Miguel de Icaza [MSFT] 2012-01-26 15:08:34 UTC
Reopening and CCing Rolf as this might be related to the other bug that we experienced in #3068
Comment 7 Rolf Bjarne Kvinge [MSFT] 2012-02-02 20:12:36 UTC
Exactly which versions of MonoTouch and MonoDevelop does this happen with?

And if it happens again, can you catch the device log (execute /Developer/MonoTouch/usr/bin/mtouch --logdev from a terminal)?
Comment 8 tkandiliotis 2012-02-03 08:02:22 UTC

actually this has not happened again after switching to WIFI. Noticed this strange thing though...

I got the update today for MonoDevelop but it said that I have an old Monotouch version? I have 5.0.4. Should I install monotouch manually cause I always thought MonoDevelop would notify me if there is a new version

just though I'd tell you in case this is meaningful info to you
Comment 9 Rolf Bjarne Kvinge [MSFT] 2012-02-09 18:20:48 UTC
The message from MonoDevelop about an old version should go away once you've installed the recently released 5.2 version.

I'll close this bug report for now, please reopen if you run into the same issue again later.