Bug 29017 - Pin Clicked does not fire (iOS at least)
Summary: Pin Clicked does not fire (iOS at least)
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Seth Rosetter
Depends on:
Reported: 2015-04-13 02:57 UTC by srobbins103
Modified: 2015-06-19 06:32 UTC (History)
12 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:

Example project recreating the problem (160.31 KB, application/zip)
2015-04-13 02:57 UTC, srobbins103

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description srobbins103 2015-04-13 02:57:36 UTC
Created attachment 10731 [details]
Example project recreating the problem

I am using (but have had it with previous versions as well).

In the app I'm developing, I wanted to clear and add pins as the map is scrolled so as not to clutter it. It seems to me that even with that PinClick is still not working properly. I have attached a sample project that recreates this - on my phone at least!

The example app has a button, a map and a label. Click the "Add Pins" button at the top of the page and it will clear existing pins and add some randomly placed ones. Clicking on a pin will change the label to "Click " + DateTime.Now.ToLongTimeString() so you can see if the click works.

For me, the first time pins are added and clicked the event works, but subsequent clearing / adding doesn't fire the event from those new pins.

I have commented on https://bugzilla.xamarin.com/show_bug.cgi?id=27621 and https://bugzilla.xamarin.com/show_bug.cgi?id=25557 to say the same, but as these are marked as resolved/closed, I was advised to open a new bug. Sorry for the scattergun approach here, I'm a little unclear on the process when you have marked bugs as closed.
Comment 1 julio 2015-04-13 07:20:06 UTC
I am also using in my project and can confirm that it is still not working.  I load the pins dynamically and none fire the click event.
Comment 2 Jon Douglas [MSFT] 2015-04-14 14:45:25 UTC
I was able to replicate this with
Comment 3 karl.kopp 2015-04-14 20:11:00 UTC
I can confirm this isn't working for me either. Works fine on Android, but not on iOS.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-13 22:10:37 UTC
Adding more standardized bug information per the bug writing guidelines:

## Steps to reproduce

1. Run the test case attached in comment 0 on either iOS simulator or device.

2. Tap the "Add Pins" button _twice_ (this is a crucial difference from similar earlier bugs like Bug 27621).

3. Tap any one of the red pins.

4. Tap within the pin annotation text box.

## Actual result

The Clicked event is not be raised, and the title bar text is _not_ updated to show the current time.

## Expected result

Clicked event _is_ raised, and the title bar text _is_ updated to show the current time.

## Version info


### Devices tested

iPhone 5s, iOS 8.2 simulator
iPad Mini 2, iOS 8.0

### OS X 10.9.5

Xamarin.iOS (f5f5a49)
Xcode 6.2 (6776), Build 6C131e
Comment 5 Jason Smith [MSFT] 2015-06-12 14:19:17 UTC
Should be fixed in 1.4.3 final
Comment 6 Parmendra Kumar 2015-06-17 14:13:29 UTC
I have checked this issue with xamarin.forms. and its working fine at my end.

Screencast: http://www.screencast.com/t/Q3zVIRj9

Hence closing this issue.

Environment info:

Xamarin Studio  5.9.3 (build 1)
Mono 4.0.1 ((detached/ed1d3ec)
GTK+ 2.24.23 (Raleigh theme)
Package version: 400010044
Xcode 6.2 (6776)
Xamarin.iOS (Enterprise Edition)
Xamarin.Android (Enterprise Edition)
Xamarin.Mac : (Enterprise Edition)
Mac OS X 10.9.4
Comment 7 srobbins103 2015-06-19 06:32:57 UTC
thanks all :)