Bug 29013 - Need to reactivate my license each time I switch using my Surface 3 Pro docking station
Summary: Need to reactivate my license each time I switch using my Surface 3 Pro docki...
Status: RESOLVED UPSTREAM
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Activation ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Greg Munn
URL:
Depends on:
Blocks:
 
Reported: 2015-04-12 12:55 UTC by christopher.wos
Modified: 2016-01-27 15:51 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description christopher.wos 2015-04-12 12:55:15 UTC
I'm using a Surface 3 Pro as my workstation. But I need to reactivate my Xamarin license each time I put it in or off the docking station. 
Obviously Xamarin recognizes two different machines. 
Machine1: Surface Pro 3
Machine2: Same Surface Pro 3 with docking station

I know about this problem since December 2014. It's a bit annoying over the time.
Comment 1 Shruti 2015-08-19 10:25:15 UTC
We don't have Surface 3 pro machine whether we have  Macbook Pro Retina , iMac, Mac Mini and Windows system and we did not experience this issue yet with these machines.

@christopher, Can you please confirm that you are still facing this issue ?  If possible please check it on another system. 
In case, you are still facing this issue please send us following detail:
1. Did you experience this with different number of environment builds ?
2. Please send us your environment info with which you are facing it. To get the detail, Go to xamarin Studio menu > About Xamarin Studio > Show details > copy information and send to us.
Comment 2 Greg Munn 2015-09-18 15:22:40 UTC
Chrisopher, is this still an issue for you?

Can you attach the IDE logs for when the Surface is docked and undocked (Help | Open Log Directory)
Comment 3 Greg Munn 2016-01-22 17:36:07 UTC
Christopher,

I've just managed get hold of a surface with the dock and I can confirm that our activation software is treating them as 2 machines, but what I can't confirm is the experience of having to log in every time I switch - for me, I just had to sign in twice and then I was done.

Can you give me any more information about how this affecting you? do you have any other computers that you've activated your licences on?
Comment 4 christopher.wos 2016-01-22 17:50:15 UTC
Sorry, I missed your comment from 2015-09-18. I can't currently provide logs. As you can reproduce this behaviour I don't think you need my logs anymore. Please tell me if I'm wrong.

I have my license bound to a build server, a Mac and the Surface Pro 3. As it is bound to three machines (which is the maximum number of machines I'm allowed to bind the license to) I need to unbind the Surface in order to rebind it with the different setup regarding the docking station.