Bug 28987 - Cant' add projects to empty solution in Xamarin Studio Version 5.9 (build 388)
Summary: Cant' add projects to empty solution in Xamarin Studio Version 5.9 (build 388)
Status: RESOLVED DUPLICATE of bug 28971
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.9
Hardware: Macintosh Mac OS
: --- major
Target Milestone: master
Assignee: Matt Ward
URL:
Depends on:
Blocks:
 
Reported: 2015-04-10 13:09 UTC by David Hathaway
Modified: 2015-04-13 18:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 28971

Description David Hathaway 2015-04-10 13:09:50 UTC
Steps to repro:

- Create a new blank solution
- Right click on solution > Add New Project

Result: New Project dialog shows briefly, but disappears after a few seconds
Comment 1 Matt Ward 2015-04-13 05:04:20 UTC
Unfortunately I am unable to repro this following the steps.

Is there anything in the IDE logs? What OS X version are you using?

I have seen this behaviour once or twice after trying to create a new solution after running UITests locally but only with a local build of Xamarin Studio, not with 5.9 installed from the alpha channel. In this case opening the new project dialog a second time worked.
Comment 2 Matt Ward 2015-04-13 05:18:54 UTC
OK it looks like it can be reproduced if you have a window which is set to auto-hide open when you open the new project dialog. It looks like the auto-hide window is being used as the parent for the new project dialog so when the auto-hide window closes it closes the new project dialog.

This problem was reported in a different bug #28971 but it may not be the same problem.