Bug 28884 - Submitting App with Apple Watch Support fails
Summary: Submitting App with Apple Watch Support fails
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 8.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-04-08 09:51 UTC by jeroen
Modified: 2016-12-22 19:12 UTC (History)
9 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description jeroen 2015-04-08 09:51:00 UTC
Apple reports "Invalid Binary" 

- Invalid WatchKit Support
- Non-public Api usage: PKService,SPPluginDelegate
Comment 1 andy 2015-04-08 10:20:24 UTC
I experiencing the same issue with XS 5.9 (Alpha Build)
In Beta Mode with XS 5.8 i can't upload a binary to iTunes Connect because of a icon bug.

I also tried to upload my app with the XS archive function but this also didn't work.
Comment 2 Pedro Fernandes 2015-04-08 11:27:38 UTC
Experiencing the same issue with XS 5.9 (latest alpha)
Comment 3 Pedro Fernandes 2015-04-08 19:38:46 UTC
Still not working with latest xCode release. seems to be a Xamarin Studio bug.
Comment 4 CraigD 2015-04-08 20:11:37 UTC

Our watchkit deployment doc has the details for the workaround for this bug (until it is fixed):


You must:
* use the Beta channel (as at 8-Apr-13)
* create an Archive in Xamarin Studio
* switch to Xcode's archive window to Submit

The missing-icon error is mentioned in the Known Issues

Comment 5 Sebastien Pouliot 2015-04-08 21:49:38 UTC
If you're using the 8.10 (alpha, as the bug fields suggest) then you'll need to either:

a. downgrade to XI (beta channel right now, as mentioned in comment #4); or 

b. wait for a newer alpha/beta of XI 8.10 to be released; or

c. wait for our next stable build (XI 8.9.2) that adds support for iOS 8.3 (along with all fixes of 8.8.x);

The archiving issue is different (XS) and the workaround is in comment #4.

*** This bug has been marked as a duplicate of bug 28609 ***
Comment 6 Brendan Zagaeski (Xamarin Team, assistant) 2015-04-09 12:19:40 UTC
I'll reopen this bug for a second look now that at least one customer on the CC list for this bug has updated to the Xamarin beta versions as well as Xcode 6.3 and rebuilt the app. The customer is still getting the "Invalid WatchKit Support" message, but now only via email _after_ the app is successfully uploaded to iTunes Connect. It seems the "Invalid WatchKit Support" message is a separate issue from the "Non-public Api usage: PKService,SPPluginDelegate".

Technically perhaps I should file a new bug for this because the error is now being sent via email, but I'll leave the discussion on this bug for now since the "new" behavior might still affect all of the customers included on CC on this bug report.

## From the forums (http://forums.xamarin.com/discussion/comment/115310/#Comment_115310)

> I installed the version from the beta channel, archived and uploaded from
> xcode. Shortly after uploading, I received an email that my binary was
> rejected. The reason was invalid watchkit support, but unfortunately, there
> were no details included:

>> Invalid WatchKit Support - The bundle contains an invalid implementation of
>> WatchKit. The app may have been built or signed with non-compliant or
>> pre-release tools. Visit developer.apple.com for more information.

## Possible explanations

1. Perhaps using Xcode 6.3 is part of the problem? Maybe the customer would need to use Xcode 6.2 until Xamarin support for iOS 8.3 support is released (as mentioned in (c) on comment 5)?

2. Perhaps somehow the build output from an old version of Xamarin Studio is still lying around. In that case, maybe double-checking that Xamarin Studio is installed, deleting all of the `bin/` and `obj/` folders in the solution directory by hand, and then rebuilding would help? (Note: I suspect this will _not_ help because the "Invalid WatchKit Support" message is now only happening via email _after_ Xcode has validated the app and successfully uploaded it to iTunes Connect.) (For Xamarin team: see also Xamarin internal bug 27987, comment 8.)

3. Maybe there's a problem related to bundle identifiers or provisioning profiles?
Comment 7 Rolf Bjarne Kvinge [MSFT] 2016-12-22 19:12:50 UTC
This has been fixed, submitting watchOS apps has worked for quite a while now.