Bug 28751 - Separator is missing in some rows from a listview in Xamarin Android
Summary: Separator is missing in some rows from a listview in Xamarin Android
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.4.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-04-03 15:36 UTC by saramgsilva
Modified: 2018-05-26 18:43 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Screenshot (96.90 KB, image/png)
2015-04-03 15:36 UTC, saramgsilva
No line in iPhone X emulator (141.92 KB, image/png)
2018-04-13 22:58 UTC, Pan

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description saramgsilva 2015-04-03 15:36:47 UTC
Created attachment 10628 [details]


In this sample:

I got an issue related with the separators from an item in a Listview control, see in attach that I have in Xamarin Android Player running in a MAC.
Comment 1 Sunil Kumar 2015-04-29 13:51:27 UTC
I have tried to reproduce this issue and not able to reproduce. I have downloaded the sample from url given in bug description. I Run the "3. Create the SessionsView" projects using Xamarin Android Player and observed that it shows separator lines between all items. No any line is missing. 

Screencast: http://www.screencast.com/t/oWkYg3ggYXiO

Please let me know if I have to follow any other steps to reproduce this issue.

Also if possible could you please provide Ide logs.
for IDE logs, Location: XS-> Help-> Open Log Directory-> ide.log (with latest timestamp).
Environment info:
=== Xamarin Studio ===

Version 5.9 (build 436)
Installation UUID: 561c7a69-0a91-4bae-ad7c-f0c79d594337
	Mono 4.0.1 ((detached/373d684)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000009

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: db1ccb6
Branch: master
Build date: 2015-04-28 22:39:42-0400

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/tajinder/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: (Enterprise Edition)

=== Build Information ===

Release ID: 509000436
Git revision: 7e8ba4cbccf7b188ce5e80a90fdc4acdedb5a83f
Build date: 2015-04-23 13:19:57-04
Xamarin addins: 21fd95f743742c5237e22023996c2800ce3f8db3

=== Operating System ===

Mac OS X 10.10.0
Darwin Tajinders-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Jason Smith [MSFT] 2016-04-08 19:31:55 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team
Comment 3 Pan 2018-04-13 22:56:40 UTC
This bug still appears in iPhone X emulator Xamarin.Forms 2.0 Pre-3.
Comment 4 Pan 2018-04-13 22:58:03 UTC
Created attachment 26263 [details]
No line in iPhone X emulator