Bug 28644 - Xamarin.Forms.Core Version=, file not found exception
Summary: Xamarin.Forms.Core Version=, file not found exception
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 5.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
Depends on:
Reported: 2015-04-01 13:35 UTC by Dinesh kumar
Modified: 2015-04-01 17:32 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

exception screenshot. (30.18 KB, image/png)
2015-04-01 14:59 UTC, Dinesh kumar

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dinesh kumar 2015-04-01 13:35:40 UTC
Error	1	Exception while loading assemblies: System.IO.FileNotFoundException: Could not load assembly 'Xamarin.Forms.Core, Version=, Culture=neutral, PublicKeyToken='. Perhaps it doesn't exist in the Mono for Android profile?
File name: 'Xamarin.Forms.Core.dll'
   at Xamarin.Android.Tuner.DirectoryAssemblyResolver.Resolve(AssemblyNameReference reference, ReaderParameters parameters)
   at Xamarin.Android.Tasks.ResolveAssemblies.AddAssemblyReferences(ICollection`1 assemblies, AssemblyDefinition assembly, Boolean topLevel)
   at Xamarin.Android.Tasks.ResolveAssemblies.Execute().

couldn't find what's wrong , can you please help me what am doing wrong or should i add any references to clear this exception.
Comment 1 Jonathan Pryor 2015-04-01 14:47:56 UTC
I suspect that your project is referencing the Xamarin.Forms NuGet package, but you haven't downloaded that package yet (fresh git checkout?).
Comment 2 Dinesh kumar 2015-04-01 14:59:19 UTC
Created attachment 10592 [details]
exception screenshot.

am referring a PCL project as a dependency to the Xamarin.Android project. Other than that am not referring any Xamarin packages, is there any way i can rectify it. 

FYI when i tried to install the Xamarin.Forms nuget packages am getting exceptions which i have attached.
Comment 3 Matt Ward 2015-04-01 16:48:56 UTC
It looks like your NuGet package manager is too old to recognise MonoAndroid as a target framework. Try updating it. You can update it by going to Tools - Extensions and Updates, select Updates, then select Visual Studio Gallery. The NuGet Package Manager should be there so select it and click the Update button.

After that you should be able to install Xamarin.Forms into an Android project.
Comment 4 Dinesh kumar 2015-04-01 17:32:05 UTC
Thanks matt, it worked.