Bug 28642 - The UIDeviceInfo class is not working for iPad mini 3
Summary: The UIDeviceInfo class is not working for iPad mini 3
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-04-01 12:46 UTC by david.dai@zyamusic.com
Modified: 2015-04-01 16:58 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description david.dai@zyamusic.com 2015-04-01 12:46:47 UTC
UIDeviceInfo will always be null on iPad mini 3. Please fix it.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-04-01 13:34:10 UTC
Xamarin.iOS does not provide a UIDeviceInfo class, where are you seeing it? Could you attach a sample project?
Comment 2 david.dai@zyamusic.com 2015-04-01 14:40:10 UTC
Sorry, the class is called UIDevice. We have changed our code to fix this bug. So I cannot provide sample code. But this class is not working on iPad mini 3. Either null or give us system runtime error.
Comment 3 Sebastien Pouliot 2015-04-01 15:08:35 UTC
@David, That's unexpected. There's no iOS version or hardware check in our code so the UIDevice type should be working identically across devices (or simulators). Can you tell us which version of iOS was used on the device ?

@Gouri since QA has some Mini3 devices (works fine on my mini2), can you try to duplicate this ? e.g. check that:

> Console.WriteLine (`UIDevice.CurrentDevice != null);

shows `True` in the application output.
Comment 4 GouriKumari 2015-04-01 16:25:38 UTC
I couldn't reproduce this issue on an iPadMini3 device.

Screencast: http://screencast.com/t/d9TGu5n1LlZ

Test Env:
Xamarin Studio
Version 5.8.1 (build 8)
Installation UUID: 5ed3a124-4b77-4c6f-beb9-c830fd815e2a
	Mono 3.12.1 ((detached/b63df7d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312010002

Apple Developer Tools
Xcode 6.2 (6776)
Build 6C131e

Version: (Enterprise Edition)
Hash: 1722273
Build date: 2015-04-01 13:07:55-0400

iPadMini3 8.1.3
Comment 5 david.dai@zyamusic.com 2015-04-01 16:39:24 UTC
Thanks for the reply. I just tried on our device, it worked, too. But it was not working two weeks ago. Sorry for reporting it so late. Maybe you guys have fixed it in the last update. Thanks a lot!
Comment 6 Sebastien Pouliot 2015-04-01 16:58:40 UTC
I cannot think of any recent change related to this. Still I'm glad if this works for you now.

If you can duplicate this in the future please re-open the bug and attach a test case/app.