Bug 2860 - Where is the AVD Location set?
Summary: Where is the AVD Location set?
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 2.8.5
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: shana@xamarin.com
Depends on:
Reported: 2012-01-12 04:58 UTC by VvdL
Modified: 2012-01-16 02:24 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description VvdL 2012-01-12 04:58:50 UTC
When i try to open the Android images through:

Project -> Android Device Target -> Manage Devices ...

I get the following error:
System.UnauthorizedAccessException: Access to the path '\\{server}\users\.android\avd' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, Object dirSecurityObj)
   at System.IO.Directory.CreateDirectory(String path)
   at MonoDevelop.MonoDroid.AvdWatcher..ctor()
   at MonoDevelop.MonoDroid.VirtualDeviceManager.StartWatcher()
   at MonoDevelop.MonoDroid.VirtualDeviceManager.add_Changed(Action`1 value)
   at MonoDevelop.MonoDroid.Gui.DeviceChooserDialog..ctor()
   at MonoDevelop.MonoDroid.ManageDevicesHandler.Run()
   at MonoDevelop.Components.Commands.CommandHandler.Run(Object dataItem)
   at MonoDevelop.Components.Commands.CommandHandler.InternalRun(Object dataItem)
   at MonoDevelop.Components.Commands.CommandManager.DefaultDispatchCommand(ActionCommand cmd, CommandInfo info, Object dataItem, Object target, CommandSource source)
   at MonoDevelop.Components.Commands.CommandManager.DispatchCommand(Object commandId, Object dataItem, Object initialTarget, CommandSource source)

As i am not the user .android this error is legimate.
I searched the IDE for this setting but i can't find it anywhere, hopefully you can tell me where this setting is so i can change this.
Comment 1 Mikayla Hutchinson [MSFT] 2012-01-12 20:36:34 UTC
This seems to be because we compute the profile directory as the parent of the My Documents directory, which is incorrect on some complex profile setups. Fixed in git.
Comment 2 VvdL 2012-01-13 06:03:01 UTC
Hi Michael,

Thank you for fixing this.
But what do you mean with git?

I see there isn't a update for MonoDevelop (i run so i don't see what i can update to get this fix.
Comment 3 Mikayla Hutchinson [MSFT] 2012-01-13 18:41:14 UTC
This is fixed in our source repositories, and will be included in the next release, probably MonoDevelop 2.8.7 (because 2.8.6 is already being prepared for release).
Comment 4 VvdL 2012-01-16 02:24:07 UTC
Hi Michael,

Do you have a rough timeline for the 2.8.7 release?

Without this bug fixed i can't use the tool because i can't run because i get the same error at that moment.