Bug 28538 - [Debug]Android application crashed as soon as it launches on device/Emulator
Summary: [Debug]Android application crashed as soon as it launches on device/Emulator
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 5.1
Hardware: PC Mac OS
: Highest blocker
Target Milestone: 5.1
Assignee: Radek Doulik
: 28533 ()
Depends on:
Reported: 2015-03-30 07:17 UTC by Mohit Kheterpal
Modified: 2015-04-03 05:52 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Mohit Kheterpal 2015-03-30 07:17:36 UTC

Comment 1 Mohit Kheterpal 2015-03-30 07:26:44 UTC
Android template application crashed in debug mode as soon as it launches on device/emulator. However it launch successfully in release mode.

Device log : https://gist.github.com/saurabh360/b8f9c96d5d0af256edc7
package console log : https://gist.github.com/saurabh360/340fc2345a10a6136fc4
IDE Log : https://gist.github.com/saurabh360/d824e585208950a49fc0

Regression Status : This issue is working fine with mono-android-5.1.0-92_2c6da8c4f07a4f07b5f8911ec4bde43da13c38ff and start occurring with mono-android-5.1.0-93_c5897163eadd11d4eeca1fa620012b7fa669f1d0

Environment info :
=== Xamarin Studio ===

Version 5.9 (build 351)
Installation UUID: 45555ffd-f3f0-4f29-9543-e369d711ab7d
	Mono 4.0.0 ((detached/21d849b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000121

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: 91e4712
Branch: master
Build date: 2015-03-27 16:00:56-0400

=== Xamarin.Mac ===

Version: (Enterprise Edition)

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/xamarin77/Desktop/android-sdk-macosx_êèéæâàçéè€ÿëïœ
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509000351
Git revision: 7773147d0e10a961d95a36780c3013254a56cb6f
Build date: 2015-03-27 15:49:40-04
Xamarin addins: edc13ec37c2a0ead2f94466e077af392dbb6b022

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin77s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 Peter Collins 2015-03-30 10:05:36 UTC
*** Bug 28533 has been marked as a duplicate of this bug. ***
Comment 3 Radek Doulik 2015-03-30 10:28:57 UTC
Looks like the shared runtime package wasn't reinstalled on the emulator.

Could you please try to run on command line:

adb uninstall Mono.Android.DebugRuntime

and then reinstall the application. Does it now run OK?
Comment 4 Mohit Kheterpal 2015-03-30 11:00:22 UTC
I have run command ./adb uninstall Mono.Android.DebugRuntime in terminal and its results in success and then again try to deploy application with XS but getting same result i.e. failed to launch. 

Please let me know if I can provide some more useful information from my side.

Comment 5 Radek Doulik 2015-03-30 16:37:47 UTC
Please try it with master branch, commit 8763f662b22cf0b0300278301b9f891e43e51dcc - it should be ready from wrench in few hours.

If it doesn't help, please attach XS Android
Comment 6 Radek Doulik 2015-03-30 16:40:09 UTC
ops, saved by mistake. Continuing from last post.

If it doesn't help, please attach XS AndroidTools log, which is written in $HOME/Library/Logs/XamarinStudio-5.0/AndroidTools.<date-and-time>.log
Comment 7 Peter Collins 2015-03-31 18:11:37 UTC
I tried 5.1-series before and after the fix and this does indeed appear to have resolved the issue,
Comment 8 Mohit Kheterpal 2015-04-03 05:52:49 UTC
I have checked this issue with mono-android-5.1.0-101_186938d9f6f094f812b39386e7d7ff8f99cb4e59 and observed that this issue is working fine now as shown in screencast : http://www.screencast.com/t/24f7oGSpB6D

Hence closing this issue.