Bug 27958 - resgen sometime crashes (unstable)
Summary: resgen sometime crashes (unstable)
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-03-12 10:46 UTC by Arsen.Shnurkov
Modified: 2017-01-12 05:15 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

resgen binary and .resx with images (1.18 MB, application/x-compressed)
2015-03-12 10:46 UTC, Arsen.Shnurkov

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Arsen.Shnurkov 2015-03-12 10:46:50 UTC
Created attachment 10294 [details]
resgen binary and .resx with images

the problem


  at <unknown> <0xffffffff>
*** Error in `/usr/bin/mono': malloc(): memory corruption: 0x0000000001fcf5c0 ***

here is more details:

some files are attached to this bug.
Comment 1 Arsen.Shnurkov 2015-03-12 10:53:15 UTC
zip archive contains run.sh file with the command to reproduce bug
Comment 3 Arsen.Shnurkov 2015-03-12 13:43:55 UTC
output of valgring:
(it shows access violation of sgen code)
Comment 5 Zoltan Varga 2015-03-12 18:36:09 UTC
What mono version is this and what os/architecture ?
Comment 6 Arsen.Shnurkov 2015-03-13 02:17:41 UTC
you can see this in logs.

mono is from master (but Mono, Version doesn't work also)
architecture is x86_64
Comment 7 Arsen.Shnurkov 2015-03-13 03:03:03 UTC
mono -V
Mono JIT compiler version 4.1.0 (branch-master/6397c8d Mon Mar 9 20:48:09 MSK 2015)

also crashes on mono 3.12.0
# mono -V
Mono JIT compiler version 3.12.0 ((detached/a813491 Fri Mar 13 09:53:49 MSK 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  amd64
	Disabled:      none
	Misc:          softdebug 
	LLVM:          supported, not enabled.
	GC:            sgen
Comment 8 Vlad Brezae 2017-01-11 23:56:40 UTC
Hello Arsen. Are you still able to get this behavior ? I have run 3 instances of run.sh in parallel for over 12 hours but wasn't able to get a crash ? I tried an older 4.0 since that was supposed to fail, on an 16.04 amd64 ubuntu. Nor was I able to repro with latest mono.

Could you provide a stacktrace of the crash if you are able to get it ? (run with MONO_DEBUG=suspend-on-sigsegv, then attach once it crashed with gdb and run "thread apply all bt")
Comment 9 Arsen.Shnurkov 2017-01-12 05:15:12 UTC
I can't reproduce it now, because i recompiled mono runtime. I believe that problem not solved, but can't provide more info now.