Bug 27717 - Mono does not working
Summary: Mono does not working
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: 3.10.0
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-03-05 16:58 UTC by Ales Ruda
Modified: 2015-04-02 16:30 UTC (History)
3 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ales Ruda 2015-03-05 16:58:33 UTC
I install mono from package http://sourceforge.net/projects/bananapi/files/mono_3.10-armhf.deb.
Instalation was success.

mono -V displays

Mono JIT compiler version 3.10.0 (mono-3.10.0-branch/ce003f4 Tue Nov 25 20:18:29 UTC 2014)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       normal
        Notifications: epoll
        Architecture:  armel,vfp+hard
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen

If I run mono Hallo.exe it is happens nothing.

using System;
using System.Collections.Generic;
using System.Text;

namespace Hallo
    class Program
        static void Main(string[] args)

I set MONO_LOG_LEVEL=debug and try mono Hallo.exe again.

Mono: Config attempting to parse: '/usr/local/etc/mono/config'.
Mono: Config attempting to parse: '/root/.mono/config'.
Mono: Assembly Loader probing location: '/usr/local/lib/mono/4.5/mscorlib.dll'.
Mono: Image addref mscorlib[0x337c60] -> /usr/local/lib/mono/4.5/mscorlib.dll[0x337200]: 2

It is all. :-(

Can any body help me?


Ales Ruda
Comment 1 Rodrigo Kumpera 2015-04-02 14:24:11 UTC
Can you run it under gdb to see if it shows anything else?

Could you update to 3.12 and use one of the official packages from: www.mono-project.com/download/
Comment 2 Ales Ruda 2015-04-02 16:30:24 UTC

thanks for answer.
I tried install official packages, but without success. Problem was in absence ARMHF version, I think. It is very long time ago.

I solved problem in another way.

I found link on mono_3.12.1-1-1_armhf.deb package on some discussion.


I install it. Works same way as 3.10 but reports additional info about incompatible version of libc. I install libc6_2.19-0ubuntu6.4_armhf.deb and mono 3.12 works fine.