Bug 2748 - Can't add to Info.plist - exception
Summary: Can't add to Info.plist - exception
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2012-01-05 11:17 UTC by Neal
Modified: 2012-01-06 14:41 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Neal 2012-01-05 11:17:37 UTC

I'm trying to add the information to my Info.plist for Facebook integration (URLScheme...) and I get an exception when attempting to make the 1st nested level item.  I'm using MD 2.8.5 (not available from pick list on this bug reporter), Mono 2.10.8 and MT 5.0.4.  (all latest stable).  Here is the exception:

System.InvalidCastException: Cannot cast from source type to destination type.
  at MonoDevelop.IPhone.PlistEditor.UrlTypeListWidget.Update () [0x00071] in /private/tmp/source/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/PlistEditor/UrlTypeListWidget.cs:89 
  at MonoDevelop.IPhone.PlistEditor.UrlTypeListWidget.<HandleDictionaryChanged>m__45 (System.Object , MonoDevelop.MacDev.PlistEditor.PObjectEventArgs ) [0x00000] in /private/tmp/source/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/PlistEditor/UrlTypeListWidget.cs:62 
  at MonoDevelop.MacDev.PlistEditor.PArray.OnAdded (MonoDevelop.MacDev.PlistEditor.PObjectEventArgs e) [0x00025] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/MonoDevelop.MacDev.PlistEditor/PListObject.cs:585 
  at MonoDevelop.MacDev.PlistEditor.PArray.Add (MonoDevelop.MacDev.PlistEditor.PObject obj) [0x0000c] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/MonoDevelop.MacDev.PlistEditor/PListObject.cs:625 
  at MonoDevelop.MacDev.PlistEditor.CustomPropertiesWidget+<CustomPropertiesWidget>c__AnonStorey4.<>m__13 (System.Object , System.EventArgs ) [0x00086] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/MonoDevelop.MacDev.PlistEditor/CustomPropertiesWidget.cs:320 
  at MonoDevelop.MacDev.PlistEditor.CustomPropertiesWidget+CellRendererButton.OnClicked (System.EventArgs e) [0x0000d] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/MonoDevelop.MacDev.PlistEditor/CustomPropertiesWidget.cs:204 
  at MonoDevelop.MacDev.PlistEditor.CustomPropertiesWidget+CellRendererButton.StartEditing (Gdk.Event evnt, Gtk.Widget widget, System.String path, Rectangle background_area, Rectangle cell_area, CellRendererState flags) [0x0000c] in /private/tmp/source/monodevelop/main/src/addins/MonoDevelop.MacDev/MonoDevelop.MacDev.PlistEditor/CustomPropertiesWidget.cs:221 
  at Gtk.CellRenderer.StartEditing_cb (IntPtr raw, IntPtr evnt, IntPtr widget, IntPtr path, Gdk.Rectangle& background_area, Gdk.Rectangle& cell_area, CellRendererState flags) [0x00000] in <filename unknown>:0
Comment 1 Jeffrey Stedfast 2012-01-05 17:33:39 UTC
Can you explain this in more detail? I'm not able to reproduce this.
Comment 2 Neal 2012-01-05 17:40:57 UTC
I double-clicked on the Info.plist and then went to Advanced.  Tried adding the Facebook URL elements.  I can click the + to add the first level URLType (or whatever it is, but then when I try to add a sub-item by clicking + I get an exception.

I later found I could add the URL data below the node listing and that worked but manually adding nodes and sub-nodes threw the exception.
Comment 3 Jeffrey Stedfast 2012-01-06 11:31:16 UTC
Okay, I've done this:

1. double-clicked on Info.plist
2. switched to the Advanced tab
3. Under the "URL Types" section, I click the button with the label "Add URL Type"

At this point, a box appears labelled "Untitled" and has an icon button and the following (empty) fields:

URL Schemes:
Role: None

There is no "+" to click, so I *assume* you mean to click the expander triangle?

4. I click the expander triangle

At this point, a table appears with the columns: Property, <empty>, Type, Value

There is 1 row in the table with the string "Add new entry" in grey text under the "Property" column and a "+" icon under the empty column header.

5. I click the "+" and a new entry is added with the values: "newNode", "-", "String", ""
6. I click the next row (the one that says "Add new entry") and a "+" sign appears under the empty column header, so I click this "+" and a new entry is added.

I repeat steps 5 & 6 ad infinitum and no exceptions are thrown.

I still cannot reproduce the problem. What am I doing wrong?
Comment 4 Neal 2012-01-06 11:43:18 UTC
No, I did not go to the URL Types section - that does work.  Do NOT work with anything below the direct plist editor at the top.
Comment 5 Jeffrey Stedfast 2012-01-06 14:41:15 UTC
okay, thanks! Now I can reproduce.

Fixed in git master, will likely end up in MonoDevelop 2.8.7 (2.8.6 is already being rolled)