Bug 27478 - XS hangs when in the android designer
Summary: XS hangs when in the android designer
Status: RESOLVED ANSWERED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer ()
Version: 5.7
Hardware: All Mac OS
: Normal normal
Target Milestone: master
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2015-02-26 17:31 UTC by Paul Johnson
Modified: 2016-01-26 19:12 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
ide log file (62.05 KB, text/plain)
2015-02-26 17:31 UTC, Paul Johnson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Paul Johnson 2015-02-26 17:31:55 UTC
Created attachment 10065 [details]
ide log file

This is a simple breakage - use the designer and very quickly the application locks up with the attached log. Requires a force quit to restart

=== Xamarin Studio ===

Version 5.7.2 (build 7)
Installation UUID: f3d1a29c-1ba2-4a83-a193-1087efe91a85
Runtime:
	Mono 3.12.0 ((detached/b8f5055)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000077

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Xamarin.iOS ===

Version: 8.6.2.22 (Business Edition)
Hash: 862702c
Branch: 
Build date: 2015-02-18 15:19:23-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/PFJ/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin.Mac ===

Version: 1.12.0.8 (Business Edition)

=== Build Information ===

Release ID: 507020007
Git revision: dcf3f486177d3e625349b51a8f3be807e3fa7712
Build date: 2015-02-24 09:14:27-05
Xamarin addins: ea7c65bb7876e4a876ab365208e94acdf8f330ef

=== Operating System ===

Mac OS X 10.10.3
Darwin Pauls-iMac.local 14.3.0 Darwin Kernel Version 14.3.0
    Thu Feb 12 18:38:33 PST 2015
    root:xnu-2782.20.34~3/RELEASE_X86_64 x86_64
Comment 1 Prashant manu 2015-02-27 00:20:45 UTC
We have checked by adding/removing multiple widgets to designer. App builds and run successfully and we are not getting XS hang issue.

Could you please provide us the test steps you followed. If problem exist with specific individual project, please attach it to bug report.

Also can you please add the logs from the following places?:
On XS IDE Log  Location: XS>Help> Open Log Directory> IDE.log file (with latest
timestamp)

Environment Info:
Xamarin Studio
Version 5.7.2 (build 7)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
 Mono 3.12.0 ((detached/b8f5055)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 312000077

Apple Developer Tools
Xcode 6.2 (6770)
Build 6C121

Xamarin.iOS
Version: 8.6.2.25 (Trial Edition)
Hash: 2c22013
Branch: 
Build date: 2015-02-25 23:24:34-0500

Xamarin.Android
Version: 4.20.0.28 (Indie Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
 Supported Android versions:
  2.1    (API level 7)
  2.2    (API level 8)
  2.3    (API level 10)
  3.1    (API level 12)
  4.0    (API level 14)
  4.0.3  (API level 15)
  4.1    (API level 16)
  4.2    (API level 17)
  4.3    (API level 18)
  4.4    (API level 19)
  4.4.87 (API level 20)
  5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Xamarin.Mac
Version: 1.12.0.8 (Indie Edition)

Build Information
Release ID: 507020007
Git revision: dcf3f486177d3e625349b51a8f3be807e3fa7712
Build date: 2015-02-24 09:14:27-05
Xamarin addins: ea7c65bb7876e4a876ab365208e94acdf8f330ef

Operating System
Mac OS X 10.10.2
Darwin Admin-Macs-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Nov 13 18:36:56 PST 2014
    root:xnu-2782.10.65~2/RELEASE_X86_64 x86_64
Comment 2 Paul Johnson 2015-02-27 07:21:30 UTC
The log file is attached to this bug report. I'm just opening and closing the axml files to get hold of the id names for the various widgets on there
Comment 3 Jérémie Laval 2015-05-04 18:50:57 UTC
Hi Paul,

Are you still getting the same issue with the latest stable?

Thanks.
Comment 4 Paul Johnson 2015-05-04 19:15:40 UTC
Yes, but it happens far less frequently now - tends to only happen with very large projects and with very complex UIs
Comment 5 Jérémie Laval 2015-05-05 09:42:46 UTC
From the log it looks like it's a semantic analysis slowness. Do you have enabled that in your settings? (Preferences > Source Analysis)

If yes you can try turning it off and see if the problem persists.
Comment 6 Paul Johnson 2015-05-05 09:49:33 UTC
The problem seems to go with the source analysis switched off
Comment 7 Jérémie Laval 2016-01-26 19:12:13 UTC
Cool, it's likely fixed on the MonoDevelop side at this stage but if you still experience it feel free to reopen and reassign this bug to Xamarin Studio > C# Binding