Bug 27099 - Removing/Deleting files fails if docked Solution Explorer closes
Summary: Removing/Deleting files fails if docked Solution Explorer closes
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Docking ()
Version: 5.7
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 5.10 (C6)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2015-02-16 10:08 UTC by jlafontaine
Modified: 2015-06-10 05:45 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description jlafontaine 2015-02-16 10:08:02 UTC
Problem:

Using a auto hiding docked Solution Explorer, removing a file from the solution fails if the dock closes.

If the mouse is used to select the appropriate remove action (delete or remove from project), Solution Explorer loses focus, disappear and the remove action silently fails.

Workaround:

Instead of using the mouse, pressing enter on the keyboard prevents Solution Explorer from losing focus and the remove action can complet successfully.
Comment 1 Udham Singh 2015-02-16 10:53:37 UTC
I have checked this issue and able to reproduce the reported behaviour. Please refer the screencast : http://www.screencast.com/t/om73dL78Xc3U

Ide Log : https://gist.github.com/Udham1/a45a98547f1f1d577c00

Environment Info :

=== Xamarin Studio ===

Version 5.7.2 (build 1)
Installation UUID: ce927b2a-2c07-44c5-b186-09cfdafba6dc
Runtime:
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1.1 (6611)
Build 6A2008a

=== Build Information ===

Release ID: 507020001
Git revision: 103486e2547553077836a5ba20a973487b983830
Build date: 2015-02-13 11:56:36-05
Xamarin addins: 8dd5b934e86ef0595c022dd3930fd40e3376ab4c

=== Operating System ===

Mac OS X 10.9.5
Darwin Xamarin76s-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 dj_technohead 2015-05-15 12:42:15 UTC
I am seeing this too. It's really annoying.
Comment 3 Matt Ward 2015-06-10 05:45:46 UTC
This seems to have been fixed in Xamarin Studio 5.8.

The null reference when trying to focus the parent window, which is the solution pad which has closed so it is null, is being handled by this commit:

https://github.com/mono/monodevelop/commit/55d5a5dd55a54ee145c294762131da8e987098af