Bug 26867 - Armv7 + Arm64 fat build is incompatible with iPhone 4s
Summary: Armv7 + Arm64 fat build is incompatible with iPhone 4s
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: XI 8.6.0
Hardware: Macintosh Mac OS
: High critical
Target Milestone: Untriaged
Assignee: Bugzilla
Depends on:
Reported: 2015-02-09 11:18 UTC by Noam Ofek
Modified: 2015-06-01 05:34 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Noam Ofek 2015-02-09 11:18:56 UTC
My Unified API Xamarin app can be built in both Armv7 and Armv7+Arm64 thin and fat build architectures. 
When I build it in Armv7 architecture I can deploy and run it on an iPhone4s. When I build it in Armv7+Arm64 architecture(s) 
I can deploy and run it on iPhone5 and above. 
Why can't I deploy Armv7+Arm64 build to iPhone 4s?

This is the error I get:

Installing application bundle writeDictToFile:1258 ==== Successfully wrote Manifest cache to /var/folders/9y/yvyksjvd38g_gnkndcw4y_100000gn/T/Xamarin.iOS_InstallShadowPath/d2d4e62f663137bab4687ec28f35467b/aead04c30517c7b5a662da00c34e58e38ac78222/ManifestCache.plist error MT1006: Could not install the application '/Users/noammeirofek/RoX/bin/RumbleTouch.app' on the device Adi’s iPhone: AMDeviceSecureInstallApplicationBundle returned: 0xe8000087 (kAMDIncorrectArchitectureError). The application was terminated by a signal: SIGHUP
Comment 1 Sebastien Pouliot 2015-02-09 11:28:43 UTC
That should be working. Can you please attach your build log ?

Add `-v -v -v -v` to the *Additional mtouch arguments** in the project options (as this will give us additional clues on how the build was done).
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-02-09 11:43:19 UTC
Also which iOS version is on the iPhone 4s?
Comment 4 Noam Ofek 2015-02-09 11:50:41 UTC
The iOS version is 7.1
Comment 5 Noam Ofek 2015-02-10 06:45:34 UTC
After updating Xamarin today this issue was solved.
Thank you.
Comment 6 Rolf Bjarne Kvinge [MSFT] 2015-02-10 07:17:34 UTC
OK, I'm closing this then.
Comment 7 Bill 2015-05-14 17:43:11 UTC
This is occurring again for me.

Xamarin Studio 5.9.1
Xcode 6.3.1

Deploy output: 

Please ensure your device is connected...
Connected to: iPhone 4S
Installing application bundle
writeDictToFile:1241 open failed for /var/folders/s6/p7zlym9539xcbpvf8l2h3q5s4trzyg/T/Xamarin.iOS_InstallShadowPath/1197b66179b2e576ccec55fc1559dae2/0c65f4670c2ad1f3054246f5046ca3c3702cd096/ManifestCache.plist : No such file or directory
MDMCacheDirectoryManifest:1315 writeDictToFile failed to write to /var/folders/s6/p7zlym9539xcbpvf8l2h3q5s4trzyg/T/Xamarin.iOS_InstallShadowPath/1197b66179b2e576ccec55fc1559dae2/0c65f4670c2ad1f3054246f5046ca3c3702cd096/ManifestCache.plist : No such file or directory
error MT1006: Could not install the application '/Users/i65781/sdGit/xactimate.ios/Xactimate.iOS/bin/Debug/XactimateiOS.app' on the device Xm8 iPhone 4S: AMDeviceSecureInstallApplicationBundle returned: 0xe8000087 (kAMDIncorrectArchitectureError).
Comment 9 Rolf Bjarne Kvinge [MSFT] 2015-05-19 04:26:50 UTC
@Bill, what's the iOS version of the device?
Comment 10 Bill 2015-05-20 12:17:35 UTC
Comment 12 Rolf Bjarne Kvinge [MSFT] 2015-05-21 03:53:49 UTC
@Bill, please check previous comment.
Comment 13 Bill 2015-05-21 12:18:00 UTC
@Rolf what do you mean? 7.1.2 is the iOS version on the device.
Comment 14 Rolf Bjarne Kvinge [MSFT] 2015-05-21 12:24:08 UTC
@Bill, can you see comment #11?
Comment 15 Bill 2015-05-21 12:31:56 UTC
@Rolf no I cannot. I got a separate email though with the info.
Comment 17 Rolf Bjarne Kvinge [MSFT] 2015-05-22 04:12:46 UTC
@Bill, that looks correct. Can you open the iOS Device Log (in Xamarin Studio, the menu View -> Pads -> iOS Device Log), connect to your device, and get the log from a failed install attempt?
Comment 18 Bill 2015-05-22 16:30:35 UTC
@Rolf Here it is: https://gist.github.com/anonymous/084ee9d9320366f29a5c
Comment 19 Rolf Bjarne Kvinge [MSFT] 2015-05-25 04:26:16 UTC
@Bill, this makes no sense, it should work just fine. Does it work if you select armv7 only as the architecture?
Comment 20 Rolf Bjarne Kvinge [MSFT] 2015-05-25 08:01:16 UTC
@Bill, can you also test an Xcode test app with armv7+arm64 architectures and see if that works?
Comment 21 Bill 2015-05-26 13:07:52 UTC
@Rolf I tested it with an Xcode app with amrv7 and arm64 and it worked just fine.
Comment 22 Rolf Bjarne Kvinge [MSFT] 2015-05-27 06:45:11 UTC
@Bill, do you have any other non-arm64 devices you can try to see if this is a problem with this particular device?
Comment 23 Bill 2015-05-27 13:26:49 UTC
@Rolf I tried an iPhone 5 and it worked. However, this device had iOS 8 on it. I do not have any iOS 7 devices to try it on other than the 4s that does not have a 64 bit processor.
Comment 24 Bill 2015-05-27 13:39:27 UTC
@Rolf I found an iPad 4 running iOS 7.1.1 and it worked just fine as well.
Comment 25 Rolf Bjarne Kvinge [MSFT] 2015-05-28 04:03:56 UTC
@Bill, that means it's likely something with this particular device. My suggestion would be to build for only armv7 when using this device (you'll even benefit from a faster build).
Comment 26 Rolf Bjarne Kvinge [MSFT] 2015-06-01 05:34:41 UTC
Closing this, since it seems to be a device-specific issue (which we can't track down without the device).