Bug 2662 - Method not found: 'System.Net.WebClient.set_CachePolicy' while running the program on Linux
Summary: Method not found: 'System.Net.WebClient.set_CachePolicy' while running the pr...
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2011-12-28 04:09 UTC by Zaid
Modified: 2012-01-10 02:44 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Zaid 2011-12-28 04:09:51 UTC
I am trying to run a C# code build on Windows Env onto the Linux Server.
But while running the program the I get following error : 

** (ReportBuilderRenderer.exe:21777): WARNING **: Missing method System.Net.WebClient::set_CachePolicy(RequestCachePolicy) in assembly /usr/lib64/mono/gac/System/, referenced in assembly /home/root1/Zaid/renderer/Renderer/ReportBuilderRenderer.exe
Unexpected error: Method not found: 'System.Net.WebClient.set_CachePolicy'.

I tried to set the Cache policy to NoCacheNoStore but still the error remains.

My redhat version is CentOS release 5.7 .

I installed mono via the command yum install mono on the current linux server.
Comment 1 Zoltan Varga 2012-01-02 13:41:50 UTC
What mono version is this ?
Comment 2 Zoltan Varga 2012-01-07 12:59:18 UTC
Comment 3 Zaid 2012-01-09 06:26:57 UTC
Hi ,

I installed it via the command yum install.
The package name which was installed is "mod_mono-1.2.1-1.el5.centos.x86_64".
Comment 4 Gonzalo Paniagua Javier 2012-01-09 10:35:30 UTC
mod_mono does not contain the System.dll file.
Also, those packages are really, really old.

The latest 2.8.x and 2.10.x have that property setter.
Comment 5 Zaid 2012-01-10 01:12:32 UTC
can you send me a link to download latest packages for CentOS release 5.7 (Final).
I tried to find the same on Net but was not available.
Comment 6 Zaid 2012-01-10 02:44:47 UTC
can you send me a link to download latest packages for CentOS release 5.7 (Final).
I tried to find the same on Net but was not available.