Bug 26531 - OutOfMemoryError Exception with Xamarin forms
Summary: OutOfMemoryError Exception with Xamarin forms
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-01-29 01:50 UTC by Prashant Cholachagudda
Modified: 2016-04-08 19:18 UTC (History)
10 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Prashant Cholachagudda 2015-01-29 01:50:03 UTC
Xamarin.Form Android app throws the OutOfMemoryError exception when we navigate between MasterDetail pages

Test case and steps to reproduce are in the private comment below
Comment 2 Alessandro Strazzari 2015-01-29 02:57:17 UTC
Probably we are experiencing the same problem!
Comment 3 Rajneesh Kumar 2015-01-29 05:44:48 UTC
I tried to reproduce this issue but not able to reproduce. To reproduce this issue I have followed the steps and instruction provided in bug description.
Steps I followed:

1. Open attached test case in XS.
2. Build and deploy it on Device (Samsung Glaxy S5: 4.4.2).
3. It will deploy, navigate all tabs.
4. Select the home page to reload the page.
5. Renavigate the tabs, and observed the following exception:
Unhandled Exception:
"[mono] System.ArgumentException: 'jobject' must not be IntPtr.Zero."

Screencast: http://www.screencast.com/t/44ETQKsxsnh

I observed that in my case I am getting the different exception. Please let me know that what steps I am missing/wrong to reproduce this issue. That will be very helpful to reproduce this issue. Below are the supplement info regarding this issue. 

Application Output: https://gist.github.com/Rajneesh360Logica/cab5ca5be1aaa26d23b9
Build Output: https://gist.github.com/Rajneesh360Logica/ab184409097871817cab
Android tools Log: https://gist.github.com/Rajneesh360Logica/d0650327762a2a5a0e0c
Ide Logs: https://gist.github.com/Rajneesh360Logica/9c6ba17f13193fd4a160
Device Logs: https://gist.github.com/Rajneesh360Logica/e0573f2ec388240c1dfe

Environment Info:


=== Xamarin Studio ===

Version 5.7.1 (build 15)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: 5c4bf93
Build date: 2015-01-27 17:37:50-0500

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 507010015
Git revision: ce24e991948c7f3d88b0194a14fc1996d848ef51
Build date: 2015-01-26 16:42:20-05
Xamarin addins: 6895e3222bfa6910524708aa0633ff3db99bc3a0

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 4 Esteban Lombardo 2015-01-30 04:01:38 UTC
I finded a temporary solution for my problem. I tried to load thumbnail instead of normal size image in ListView Row and the problem doesn't reproduce anymore.

I tested my application with Samsung S3 (Android 4.3), Samsung S4 (Android 4.4), Zenfone 5 (Android 4.4) and LG G2 (Android 4.4).

With Normal size image, each telephone crashed but with Thumb no.

However the problem persist with large image!
Comment 5 Michael Rumpler 2015-02-13 02:22:43 UTC
This seems to be the same bug as https://bugzilla.xamarin.com/show_bug.cgi?id=22510
Comment 6 Rui Marinho 2016-04-08 19:18:49 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team