Bug 26434 - SIGABRT when compiling MonoGame
Summary: SIGABRT when compiling MonoGame
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-01-26 16:44 UTC by Drew DeVault
Modified: 2015-02-05 13:09 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Drew DeVault 2015-01-26 16:44:56 UTC
Side note: bug tracker doesn't let me specify mono 3.12.0, which is the version I'm using.

When I attempt to compile MonoGame on Arch Linux (x64), I get a SIGABRT at the very end of the process (after it successfully compiles with nant), presumably during some cleanup operation:

     [exec] /tmp/yaourt-tmp-sircmpwn/aur-monogame-git/src/monogame/MonoGame.Framework.Linux.sln (Build) ->
     [exec] (Build target) ->
     [exec] /tmp/yaourt-tmp-sircmpwn/aur-monogame-git/src/monogame/Tools/Pipeline/Pipeline.Linux.csproj (default targets) ->
     [exec] /usr/lib/mono/4.5/Microsoft.CSharp.targets (CoreCompile target) ->
     [exec]  Common/PipelineProjectParser.cs(78,22): warning CS0414: The private field `MonoGame.Tools.Pipeline.PipelineProjectParser._rebuild' is assigned but its value is never used
     [exec]  Common/PipelineProjectParser.cs(86,22): warning CS0414: The private field `MonoGame.Tools.Pipeline.PipelineProjectParser._clean' is assigned but its value is never used
     [exec]   100 Warning(s)
     [exec]   0 Error(s)
     [exec] Time Elapsed 00:00:05.9800230


Total time: 13.2 seconds.

Error destroying handle 0x40d mutex due to 16


  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Threading.InternalThread.Thread_free_internal (System.Threading.InternalThread,intptr) <0xffffffff>
  at System.Threading.InternalThread.Finalize () <0x0001b>
  at (wrapper runtime-invoke) object.runtime_invoke_virtual_void__this__ (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	/usr/lib/libmonosgen-2.0.so.1(+0xcf1da) [0x7f5f676921da]
	/usr/lib/libpthread.so.0(+0x10210) [0x7f5f673b7210]
	/usr/lib/libc.so.6(gsignal+0x37) [0x7f5f67037a97]
	/usr/lib/libc.so.6(abort+0x16a) [0x7f5f67038e6a]
	/usr/lib/libmonosgen-2.0.so.1(+0x25a5e9) [0x7f5f6781d5e9]
	/usr/lib/libmonosgen-2.0.so.1(+0x25a85c) [0x7f5f6781d85c]
	/usr/lib/libmonosgen-2.0.so.1(+0x25a92f) [0x7f5f6781d92f]
	/usr/lib/libmonosgen-2.0.so.1(+0x2299cd) [0x7f5f677ec9cd]
	/usr/lib/libmonosgen-2.0.so.1(+0x22b414) [0x7f5f677ee414]
	/usr/lib/libmonosgen-2.0.so.1(+0x1b5356) [0x7f5f67778356]

Debug info from gdb:

ptrace: Operation not permitted.
No threads.

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.

/usr/bin/nant: line 1: 14193 Aborted                 (core dumped) /usr/bin/mono /usr/share/NAnt/bin/NAnt.exe "$@"
Comment 1 Zoltan Varga 2015-01-26 20:39:06 UTC
Is this reproducible ?
Comment 2 Drew DeVault 2015-01-26 20:39:52 UTC
Yep, it happens every time.
Comment 3 Zoltan Varga 2015-01-26 21:25:40 UTC
How can I reproduce this ?
Comment 4 Drew DeVault 2015-01-26 22:57:21 UTC
I tried it on a different PC and it worked correctly. Is there some more information I can get from the affected computer?
Comment 5 Drew DeVault 2015-02-05 13:09:23 UTC
It was the Linux OOM killer. Sorry about that.