Bug 26336 - Unknown MSBuild failure
Summary: Unknown MSBuild failure
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: MSBuild ()
Version: Master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Chris Hamons
Depends on:
Reported: 2015-01-23 08:39 UTC by Stephen Lavelle
Modified: 2015-01-23 09:37 UTC (History)
1 user (show)

Is this bug a regression?: ---
Last known good build:

trying to compile this gives the bug (3.48 MB, application/zip)
2015-01-23 08:39 UTC, Stephen Lavelle

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Stephen Lavelle 2015-01-23 08:39:30 UTC
Created attachment 9464 [details]
trying to compile this gives the bug

using xamarin studio 5.7 build 661
osx 10.10.1

Got this error, not sure what I did to cause it.  Tried building again/deleting binary files/doing a clean build/restarting my computer, but still the same error.

"/Users/stephenlavelle/Documents/AbstractSausageSim copy/AbstractSausageSim/AbstractSausageSim.csproj(1,1): Error: Unknown MSBuild failure. Please try building the project again (AbstractSausageSim)"

I've uploaded the Xamarin studio log files here - http://ded.increpare.com/~locus/saus/errorlogs.zip


tried the alpha branch of xamarin (5.7.1) and it happened there as well.

Comment 1 Stephen Lavelle 2015-01-23 09:01:26 UTC
So, I found the build output panel (which I had never needed before) and it gave me what the actual problem was in my code (an unexpected symbol syntax error).  Gonna let you guys decide whether or not this is still a bug.

"Build started 23/01/2015 14:58:53.
Project "/Users/stephenlavelle/Documents/AbstractSausageSim/AbstractSausageSim/AbstractSausageSim.csproj" (Build target(s)):
	Target PrepareForBuild:
		Configuration: Debug Platform: x86
	Target GenerateSatelliteAssemblies:
	No input files were specified for target GenerateSatelliteAssemblies, skipping.
	Target GenerateTargetFrameworkMonikerAttribute:
	Skipping target "GenerateTargetFrameworkMonikerAttribute" because its outputs are up-to-date.
	Target CoreCompile:
		Tool /Library/Frameworks/Mono.framework/Versions/3.12.0/lib/mono/4.5/mcs.exe execution started with arguments: /noconfig /debug:full /debug+ /optimize- /out:obj/x86/Debug/AbstractSausageSim.exe Program.cs Properties/AssemblyInfo.cs Game/Misc/Utilities.cs Game/Structures/InputDirection.cs Game/Structures/GameState.cs Game/Processes/Game.cs Game/Structures/Entity.cs Game/Structures/EntityType.cs Game/Structures/Direction.cs Game/Structures/Coord.cs Game/Structures/Movement.cs Game/Misc/Fraction.cs Game/Misc/ParseUtils.cs Game/Processes/Levels.cs Game/Processes/Scenario.cs Game/Structures/Graph/Graph.cs Game/Processes/GraphAlgorithms.cs Game/Structures/Graph/Vertex.cs Game/Structures/Graph/Edge.cs Game/Processes/GraphTraversal.cs Game/Misc/Renderer.cs Game/Structures/Graph/AbstractMovement.cs Game/Structures/Graph/MetaGraph.cs /target:exe /define:DEBUG /nostdlib /platform:x86 /reference:/Library/Frameworks/Mono.framework/Versions/3.12.0/lib/mono/4.5/System.dll /reference:/Library/Frameworks/Mono.framework/Versions/3.12.0/lib/mono/4.5/System.Core.dll /reference:/Library/Frameworks/Mono.framework/Versions/3.12.0/lib/mono/4.5/mscorlib.dll /warn:4
Game/Processes/Levels.cs(186,5): error CS1010: Newline in constant
Game/Processes/Levels.cs(195,214): error CS1525: Unexpected symbol `

---------------------- Done ----------------------"
Comment 2 Chris Hamons 2015-01-23 09:37:14 UTC
Thanks for the report. We know we need to improve the error parsing logic so you don't need to check the log, but that's a known area for improvement, so I'm going to close this bug.