Bug 26049 - Updating project to unified API results in runtime crash
Summary: Updating project to unified API results in runtime crash
Status: RESOLVED DUPLICATE of bug 26184
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
Depends on:
Reported: 2015-01-14 22:49 UTC by Kent
Modified: 2015-01-23 22:44 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Symbolicated crash dump file (51.55 KB, text/plain)
2015-01-14 22:49 UTC, Kent

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Kent 2015-01-14 22:49:56 UTC
Created attachment 9361 [details]
Symbolicated crash dump file

I tried updating my project from the classic API to the unified API and it has resulted in a runtime crash when the app starts (see attached crash report).

To reproduce:

1. Clone https://github.com/kentcb/WorkoutWotch.git (stay on master)
2. Build any of Debug/Release/Ad-hoc, run on a device and note that it works (does not crash on startup)
3. Switch to the unified-api branch (may need to restart XS)
4. Rebuild any configuration and notice that the app crashes on startup

Interestingly, switching the Supported architectures from ARMv7+ARM64 back to ARMv7 allows the app to run, so it would appear to be related to 64-bit support.
Comment 1 Sunil Kumar 2015-01-19 11:27:36 UTC
I have tried to reproduce this issue and getting the same behavior. I followed the steps mentioned in bug description to reproduce this issue.

We run the sample from master branch and observed that it works fine. But if we run the sample from unified-api branch then app crashes on the startup and after switching the Supported architectures from ARMv7+ARM64 back to ARMv7, app runs successfully.

Application Output: https://gist.github.com/RamChBachkheti/a1f5cb8bf317f57e546b
Device Log: https://gist.github.com/RamChBachkheti/40ad2b8438fbc611acf6
IDE Log: https://gist.github.com/RamChBachkheti/e1cb02ca95ed2de3853c

Environment info:
=== Xamarin Studio ===

Version 5.7.1 (build 13)
Installation UUID: 2939b8b4-8977-42bd-82d6-100275ccd9cd
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.2 (6758)
Build 6C107a

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: dd1b996
Build date: 2015-01-15 15:06:20-0500

=== Xamarin.Mac ===

Version: (Enterprise Edition)

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/360_macmini/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		1.6   (API level 4)
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Build Information ===

Release ID: 507010013
Git revision: 8e357d6be321e716f361ebc9591e4cee7f217c21
Build date: 2015-01-15 14:23:22-05
Xamarin addins: a6842a7727f64e956f942b8160f7835c9d9076a4

=== Operating System ===

Mac OS X 10.9.4
Darwin 360-MACMINIs-Mac-mini-2.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-01-19 11:33:12 UTC
Zoltan, this looks like an arm64 issue, since it only happens with arm64.

I get this exception at startup: https://gist.github.com/rolfbjarne/a5fa0bcc2ae983673251 with the test case (you might have to disable iCloud in the Entitlements.plist for the sample to deploy properly).
Comment 3 Zoltan Varga 2015-01-20 23:20:16 UTC
This is the same as #26184.

*** This bug has been marked as a duplicate of bug 26184 ***
Comment 4 Kent 2015-01-23 20:55:57 UTC
Bug 26184 purports to be fixed in 8.6, but I am running indie and Sunil is running enterprise. What am I missing here?
Comment 5 Zoltan Varga 2015-01-23 21:01:15 UTC
Fixed means the bug is fixed in our development version, it takes time for bug fixes to reach a release.
Comment 6 Kent 2015-01-23 21:26:12 UTC
Understood, sorry I missed the comment about it being fixed in

*** This bug has been marked as a duplicate of bug 26184 ***