Bug 26032 - ListView ItemTapped doesn't get called for the selected item (Xamarin.Forms 1.3, iOS)
Summary: ListView ItemTapped doesn't get called for the selected item (Xamarin.Forms ...
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
Depends on:
Reported: 2015-01-14 15:38 UTC by Sten
Modified: 2015-07-21 09:45 UTC (History)
7 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

sample project (290.13 KB, application/x-zip-compressed)
2015-06-11 10:32 UTC, Michael Rumpler

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Sten 2015-01-14 15:38:44 UTC
If an item is selected in a ListView tapping the row doesn't fire the ListView.ItemTapped. The event is fired for all other items in a list
Comment 1 Naqeeb 2015-01-15 12:22:35 UTC
Hi Sten,

We have checked this issue with the help of sample 'WorkingWithListview' and observed that listView ItemTapped event is called when we click on any listview item. Please refer the screencast : http://www.screencast.com/t/Kuev99bEu

We have used sample 'WorkingWithListview', which we can download from  http://developer.xamarin.com/samples/WorkingWithListview/

Could you please provide a sample app with test steps that demonstrate this issue? So that we can reproduce this issue our end. 

Also please include your environment info. You can get environment info via 'Xamarin Studio > About Xamarin Studio > Show details > Copy Info and paste it here.'

Comment 2 Michael Rumpler 2015-06-11 10:32:53 UTC
Created attachment 11570 [details]
sample project

I get the same error. But it only happens, if the Cells use ContextActions.

I attached a sample project which demonstrates the issue. This sample displays two lists. The left list is without context actions and works as expected. In the right list, the TextCells have a ContextAction. If you tap on the selected item in the right list, ItemTapped will not be raised.

I tested it with Xamarin.Forms. and Xamarin.Forms. on an iPad2. On Android and WinPhone it works as expected.

This project also demonstrates different errors with the ContextActions:
-) When you swipe to show the context action for the selected item, the action is shown immediately without animation. On a not-selected cell, this is animated.
-) The context action for the selected item stays visible if you swipe on a different cell to show that context action. All other context actions are closed before a new one is shown.

Should I file a separate bug for these issues?
Comment 3 Jason Smith [MSFT] 2015-06-17 03:26:06 UTC
Updating status
Comment 4 Michael Rumpler 2015-06-17 03:27:26 UTC
Tested with, but all three problems are still unchanged.
Comment 5 Rui Marinho 2015-06-18 16:59:46 UTC
I m not being able to reproduce this on the device with the provided sample. 
Michael do you have the same behaviour on the device ?
Comment 6 Michael Rumpler 2015-06-19 03:12:46 UTC
Yes, I originally tested it on an iPad 2.
I also powered up my old iPhone 3GS (iOS 6.1.6) now and tried there. The Tapping event fails there too. The ContextAction on the selected item does not work at all (the whole Cell becomes black).

The simulator for iPhone 6, iPad Air and iPhone 4s all show the same behavior as the iPad 2.

In the left list, the events work as they should. In the right list "Item x tapped" does not appear when you tap the selected item.

I could also see the other errors with the ContextActions in the iPhone 4s simulator (didn't try in the others).
Comment 7 Rui Marinho 2015-06-26 11:13:22 UTC
Should be fixed in 1.4.4
Comment 8 Rui Marinho 2015-06-26 11:13:49 UTC
Michael the issues you reported too.
Comment 9 Michael Rumpler 2015-07-15 08:56:24 UTC
Yes, I can confirm it's fixed with Thanks!
Comment 10 Parmendra Kumar 2015-07-21 09:45:26 UTC
I have checked this issue with X.F 1.4.4-pre3 and its working fine at my end.

Screencast: http://www.screencast.com/t/UMsUDj9YF

Hence closing this issue.