Bug 26001 - When creating a new project Forms PCL app in Visual Studio on 1.3.1, I does not build.
Summary: When creating a new project Forms PCL app in Visual Studio on 1.3.1, I does n...
Status: RESOLVED DUPLICATE of bug 23210
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-01-14 04:17 UTC by Joost van Schaik
Modified: 2016-04-29 21:37 UTC (History)
6 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Joost van Schaik 2015-01-14 04:17:53 UTC
Error in Error list:

Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'App4, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile?	App4.Droid

The solution is pretty simple - select configuration manager, iPhoneSimulator and then check the PCL lib at build. I presume an error in the template project
Comment 1 Sunil Kumar 2015-01-14 06:16:13 UTC
I have tried to reproduce this issue and not able to reproduce. I created Xamarin.Forms PCL project and build it and observed that It build successfully without any error.

Screencast: http://www.screencast.com/t/SHS91ByVA

Please let me know if I have to follow any other steps to reproduce this issue at my end.

Also if possible could you please provide IDE log, Build Output and Build info.

For VS IDE log: Location: C:\User\AppData\Local\Xamarin\Log\
For VS Build Output: VS-> View-> Output-> Build 
For VS Build info: VS-> Help-> About Microsoft Visual Studio

Environment info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Xamarin (7882a10)
Xamarin.Android (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS (dfb682fa615491b012ed24198d2bdcd641e1874f)
Comment 2 Joost van Schaik 2015-01-14 07:15:59 UTC
I should have been more clear. 

Have you tried deploying to iOS using iPhoneSimulator? I get an error the PCL cannot be loaded
Comment 3 Jason Smith [MSFT] 2015-02-13 21:06:24 UTC
What version of Visual Studio are you using? Sounds like 2010?
Comment 4 Paul DiPietro [MSFT] 2016-04-08 19:21:17 UTC
Thank you for your bug report. As we have not received the information requested, we cannot properly triage your bug and are marking it resolved.

Warm regards,
Xamarin Forms Team
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2016-04-29 21:37:02 UTC
I will mark this as a duplicate of an older bug about this same "Could not load assembly" _warning_.

Note that this message can also appear as an _error_. I have filed a separate bug about improving the wording of the _error_ in Bug 40782.

*** This bug has been marked as a duplicate of bug 23210 ***