Bug 25859 - Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'Xamarin, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for A
Summary: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. R...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms ()
Version: 4.0.0 (C6)
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-01-09 02:33 UTC by leoluis
Modified: 2016-12-22 21:39 UTC (History)
11 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description leoluis 2015-01-09 02:33:33 UTC
Created a fresh new Xamarin PCL Project and tried to build and it fails.
Comment 1 Gowtham 2015-02-26 04:32:17 UTC
Same Error occurs to me.
Comment 2 Kira 2015-05-18 13:34:07 UTC
Same one happens after solution creating.
Comment 3 Gerard Daa,s 2015-08-14 06:32:27 UTC
Same happens to me. If I Clean the app and the rebuild it I get the warning message @(Content) build action not supported
Comment 4 Tomas Menezes 2015-09-15 12:07:16 UTC
Same error occurred with me.
Comment 5 Michael 2016-01-08 12:33:25 UTC
Same error on my brand new HP envy happens with a fresh install of Xamarin and VS 2015
Comment 6 callanr 2016-01-12 18:18:42 UTC
Just got this while trying to do exercise 3 of the Xamarin University "Intro to Cross-Platform Mobile Development" class.
Comment 7 robyn_dessoy 2016-04-21 13:07:49 UTC
Happens to me too. Just downloaded & installed Xamarin & Xamarin player, tried to create a new project and it appeared.
Comment 8 Daniel Cazzulino 2016-04-29 14:33:33 UTC
Could you provide a sample solution that reproes the issue and do a build with detailed verbosity? Does this fail also if you build from command line? Does this still repro with the latest Xamarin.Forms 2.2 (pre-release ATM) nuget package and the latest beta version of Xamarin (4.1.*)?

Finally, could you please provide the Help > About version information from VS?

Comment 9 Jose Gallardo 2016-12-22 21:39:32 UTC
I'll mark the bug tentatively as resolved fixed based on the several improvements since the bug was reported.
Please feel free to reopen it if you can still reproduce the issue with current bits.