Bug 25838 - Visual Studio does not detect that a NuGet package is referencing monotouch.dll after migrating to the Unified API
Summary: Visual Studio does not detect that a NuGet package is referencing monotouch.d...
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 3.9
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2015-01-08 12:20 UTC by John Miller [MSFT]
Modified: 2016-12-22 21:37 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description John Miller [MSFT] 2015-01-08 12:20:25 UTC

   After migrating an iOS project to the unified API, VS does not show an error for any referenced packages that might be referencing monotouch.dll. 

**Steps to Reproduce:**

   I had a Classic API iOS project referencing the Xam.Plugins.Settings NuGet package.
   Migrated this to the Unified API using the automatic tooling
   Rebuilt the project and it compiles fine in Visual Studio. 
   I open the same solution in Xamarin Studio on the Mac and it fails to compile, with an error that both monotouch.dll and Xamarin.iOS.dll cannot be referenced in the same project. Xam.Plugins.Settings is still referencing monotouch.dll. 

**Actual Results:**

   VS compiles the project ok, but I dont think it should because the NuGet package is still referencing monotouch.dll

**Expected Results:**

   The same error that XS produces. 

**Build Date & Platform:**

   XVS 3.9
   VS 2013 Update 4
   XS 5.7

**Additional Information:**

   To actually fix the issue in XS, you have to remove the NuGet packages and re-add them so the correct dll for unified is added. Updating the NuGet package does not choose the correct unified dll from the nuget target.
Comment 1 Sunil Kumar 2015-01-13 09:17:27 UTC
I have tried to reproduce this issue but not able to reproduce. I followed below steps to reproduce this issue:

1. Create a classic API iOS project in VS.
2. Added "Settings Plugins for Xamarin and Windows" NuGet package to project.
3. Build the project.
4. Migrate this to the Unified API project using automatic tooling.
5. Rebuild the project and it complies fine in VS.
Here is the screencast for the same: http://www.screencast.com/t/1wwreL1incwS

6. Opened the same project in XS on Mac.
7. Clean and Build the solution.

I observed that it build successfully in XS on Mac without giving any error. Here is the screencast for the same:  http://www.screencast.com/t/ut6hUhiSm2L

Please let me know if I have to follow any other steps to reproduce this issue.

Also if possible could you please provide IDE log, Build output of XS and VS.
For XS IDE log: Location: XS->Help->Open Log Directory->IDE.log
For XS Build Output: XS-> View-> Pads-> Errors-> Build Output

For VS IDE log: Location: C:\User\AppData\Local\Xamarin\Log\
For VS Build Output: VS-> View-> Output-> Build 

Environment info:
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Xamarin (7f1c1f6)
Xamarin.Android (49a04b966feb40dfdba49d57ba16249b66d606a6)
Xamarin.iOS (dfb682fa615491b012ed24198d2bdcd641e1874f)

=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 93e693b0-b53d-40f4-b29c-b61ff5cbe892
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.1 (6604)
Build 6A1052d

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: 7c4c2c5
Build date: 2015-01-08 22:29:16-0500

=== Xamarin.Android ===

Version: (Business Edition)
Android SDK: /Users/xamarin23/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.10.0
Darwin 800BC.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Jose Gallardo 2016-12-22 21:37:42 UTC
Based on Comment 1, marking this issue as Resolved NotReproducible.