Bug 25789 - [Crash] Maybe a drag and drop caused crash
Summary: [Crash] Maybe a drag and drop caused crash
Status: RESOLVED DUPLICATE of bug 35699
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 5.7
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2015-01-07 13:15 UTC by Stephen Shaw
Modified: 2015-11-10 13:01 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 35699

Description Stephen Shaw 2015-01-07 13:15:56 UTC
Not sure exactly what caused this crash, but I was trying to take a screenshot (command+shift+4) and clicking and drag and XS crashed (native crash). Here are the gists:

https://gist.github.com/decriptor/aafe0be6ebdb6508a747
https://gist.github.com/decriptor/f4c149b16d16d52560cd
Comment 1 Cody Russell 2015-01-07 13:21:05 UTC
[12:19 PM] Stephen Shaw: the gist of it is the UI freezes, I try to take a screenshot and click/drag roughly at the same time
Comment 2 Jatin 2015-01-08 05:40:06 UTC
I have tried to reproduce this issue at my and, but I am not able to reproduce it. As when I try to take a screenshot (command+shift+4) and clicking and drag. It does not crash the XS

I have used the latest build in order to reproduce this issue below is the build information for the same:

=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: 449f40dd-b3f1-4028-9a6b-cca0d1a2307d
Runtime:
 Mono 3.12.0 ((detached/a813491)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 312000068

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 8.6.0.50 (Business Edition)
Hash: 561dfed
Branch: 
Build date: 2015-01-06 17:56:14-0500

=== Xamarin.Android ===

Version: 4.20.0.28 (Business Edition)
Android SDK: /Users/360logicaxamarinmacmini/Desktop/android-sdk-macosx_AndÃsdk
 Supported Android versions:
  1.6    (API level 4)
  2.1    (API level 7)
  2.2    (API level 8)
  2.3    (API level 10)
  3.1    (API level 12)
  4.0    (API level 14)
  4.0.3  (API level 15)
  4.1    (API level 16)
  4.2    (API level 17)
  4.3    (API level 18)
  4.4    (API level 19)
  4.4.87 (API level 20)
  5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: 1.11.3.0 (Business Edition)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.8.4
Darwin 360LogicasMacmini.local 12.4.0 Darwin Kernel Version 12.4.0
    Sun Mar 10 18:01:10 PDT 2013
    root:xnu-2050.24.6~1/RELEASE_X86_64 x86_64

If this issue is still reproducible at your end using the above mentioned builds, the please provide us with some more information such as:

1. Detailed steps
2. Video demonstrating the issue.

As of now I am leaving this issue as New.
Comment 3 Shruti 2015-01-13 02:55:05 UTC
In addition to comment 2, If you still facing this issue Please provide the build information also with detailed information asked in comment 2.
Steps to get build information. Go to Xamarin Studio >> About  Xamairn Studio >> Show Details >> Copy Information.
Comment 4 Cody Russell 2015-11-10 13:01:09 UTC
Looking at the stacktrace again, it seems like the same thing we're occasionally seeing in the designer.

*** This bug has been marked as a duplicate of bug 35699 ***