Bug 25598 - Infinite "Xamarin iOS SDK Update Available" message
Summary: Infinite "Xamarin iOS SDK Update Available" message
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.0.0 (C6)
Hardware: PC Windows
: High normal
Target Milestone: 3.9
Assignee: Jose Gallardo
Depends on:
Reported: 2014-12-23 17:26 UTC by Ian
Modified: 2015-01-06 07:53 UTC (History)
5 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Ian 2014-12-23 17:26:30 UTC
I have updated (Beta channel) my Mac and Visual Studio 2013 to the newest everything. However when I run VS2013, I get the message that a SDK update is available. So I update. Reboot and run VS2013 again. Then the message appears again. Repeat.

Is this a bug, or am I doing something wrong?

See Forums Discussion for many with this issue: http://forums.xamarin.com/discussion/comment/94332#Comment_94332
Comment 1 joshcomley@googlemail.com 2014-12-24 18:14:53 UTC
Same problem here, but as far as I can tell it just downloads the zip and then doesn't actually install it. I've tried manually extracting the zip to the right locations but it still prompts the error. What is worse is that now I can't deploy iOS at all :( no error, it just won't even deploy a brand new project
Comment 2 joshcomley@googlemail.com 2014-12-24 18:38:38 UTC
I managed to get the SDK synchronised by completing the following:

Copy the class libraries from the build host:


Into the corresponding Windows directory:

"C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\"

Copy the PCL facades from the build host:

Into the corresponding Windows directory:

"C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\MonoTouch\v1.0\Facades"

But it still doesn't compile :(
Comment 3 joshcomley@googlemail.com 2014-12-24 18:48:57 UTC
To be more accurate:
- Each project compiles individually
- A "Rebuild all" fails without any error
- I can deploy to the iOS emulator
- But attempting to deploy to my phone gets: "Failed to deploy application on the target device. Please try to rebuild the solution and try again."
Comment 4 joshcomley@googlemail.com 2014-12-24 19:01:40 UTC
More news...
Actually, the "manual" updating of the SDK didn't work. I also tried copying the files to:

"C:\Program Files (x86)\Reference

But that didn't fix it.

However, I am able to run the iOS app in Release mode and deploy that, although no buttons seem to be actually working all of a sudden?! This is very strange.
Comment 5 joshcomley@googlemail.com 2014-12-24 19:42:09 UTC
I am using VS2015, I have the latest beta channel of Xamarin installed on both my Mac and my PC (which is the only channel that supports VS2015) and since updating to the latest Xamarin.Forms and subsequently the latest beta, iOS has been thoroughly killed.
Comment 6 joshcomley@googlemail.com 2014-12-24 19:58:06 UTC
Also: I keep "losing" the connection to my build host since updating everything, but only during build
Comment 7 joshcomley@googlemail.com 2014-12-28 19:32:31 UTC
I don't know what had gone wrong but after uninstalling and re-installing Xamarin on Windows the build works now, but the SDK sync issue is still there
Comment 10 Mohit Kheterpal 2015-01-06 07:53:21 UTC
I have checked this issue using XVS 3.9.235 + X.iOS and now we are getting expected behaviour mention in comment 9. i.e. SDK sync option is not available now as shown in screencast : http://www.screencast.com/t/hyRFaSscnw

Hence closing this issue.