Bug 25553 - Copy/paste does not work
Summary: Copy/paste does not work
Status: RESOLVED DUPLICATE of bug 16519
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 5.7
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2014-12-21 03:15 UTC by Dmitry
Modified: 2015-01-09 07:57 UTC (History)
4 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:


Attachments
demonstration of a bug (1.62 MB, image/gif)
2014-12-21 03:17 UTC, Dmitry
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 16519

Description Dmitry 2014-12-21 03:15:08 UTC
Hi. Forgive for my bad English.

When I try to insert the text copied in other program, it isn't inserted. Sometimes nothing happens, and sometimes can be inserted a blank line or some garbage. 
Special steps for reproduction of a problem aren't present. This happens after some time of intensive work in the Xamarin Studio (and switching between programs). If to restart XS, everything will correctly work. In the attached animation I am trying to copy text from Sublime Text editor to a working project in the XS. The bug is present at any 5.x version (I didn't work in earlier versions).

As I already wrote in order that the problem disappeared, it is necessary to restart XS.
But sometimes (I have not tried to calculate the exact sequence of actions and I didn't check, whether it helps always, because usually I restart XS) the following sequence of actions helps:
- select a line of text in the XS, copy it to the clipboard (ctrl+c)
- switch to Sublime, insert a clipboard (ctrl+v)
- select a line of it text in the Sublime, copy it to the clipboard (ctrl+c)
- switch to XS, insert a clipboard (ctrl+v)
then copy/paste begins to work correctly
Comment 1 Dmitry 2014-12-21 03:17:03 UTC
Created attachment 9158 [details]
demonstration of a bug
Comment 2 asimk 2014-12-29 12:43:53 UTC
@Dmitry, I have checked this issue with the help of bug description, I have used "Sublime Text editor" to reproduce this issue but I am unable to reproduce this issue. I am able to copy and paste text in Xamarin Studio editor successfully.

Please refer the screencast:
http://www.screencast.com/t/p7aaPKS4pM

Can you please provide complete build info via Help-> About-> Show Details'? So that I can reproduce this issue at my end. 

Test Environment:
Xamarin Studio
Version 5.5.4 (build 15)
Installation UUID: b6495454-eed9-49ee-a97b-abf8a686d664
Runtime:
Microsoft .NET 4.0.30319.34003
GTK+ 2.24.22 (MS-Windows theme)
GTK# 2.12.26

Xamarin.Android
Version: 4.20.0 (Business Edition)
Android SDK: D:\SDK\AndroidSDK

Build Information
Release ID: 505040015
Git revision: f93940a35458a18052f1a25e106e62ca970d9c40
Build date: 2014-11-19 13:26:21-05
Xamarin addins: dc23cbd91a3a0e1d326328e1229e86c942a49ec8

Operating System
Windows 6.2.9200.0 (64-bit)
Comment 3 Dmitry 2014-12-29 13:09:35 UTC
Hi, asimk. How I already wrote:
> Special steps for reproduction of a problem aren't present. This happens
> after some time of intensive work in the Xamarin Studio (and switching
> between programs).
i.e. usually copy/paste works normally. But after some time it happens. Sometime after 1 hour. Sometime after 5 hours. Sometime after 3 hours... When I intensively work with studio, it happens surely. And as I wrote, I had it on any 5.x versions.

details:
Xamarin Studio
Version 5.7 (build 660)
Installation UUID: 104fb403-89c5-452a-8ef8-e39bb4a17653
Runtime:
	Microsoft .NET 4.0.30319.18444
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

Xamarin.Android
Not Installed

Build Information
Release ID: 507000660
Git revision: 6a74f9bdb90d9415b597064d815c9be38b401fee
Build date: 2014-12-17 23:51:00-05
Xamarin addins: 57be0f5e1433cb58b70ea9b52e9dc77ad791be40

Operating System
Windows 6.1.7601.65536 (64-bit)
Comment 4 asimk 2014-12-29 13:32:16 UTC
As I have tried to reproduce this issue many times but not able to reproduce and @Dmitry has also mentioned that there is no specific steps to reproduce this issue. I think this issue seems to be an intermittent issue.

So I am leaving this issue as "New", we may have to see if a developer can figure out what's going on.
Comment 5 Mike Krüger 2015-01-05 07:07:33 UTC
We're aware of copy/paste problems on windows.
Comment 6 Matt Ward 2015-01-09 07:57:58 UTC
Another workaround for this is to right click the tab at the top of the open text editor, then select Copy file path/name. Then you can copy text from the other application and paste it into the text editor again. This is quicker than restarting Xamarin Studio.

We are tracking the text editor copy/paste problems on Windows in bug #16519 so I am marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 16519 ***