Bug 25407 - migration tool set wrong arch
Summary: migration tool set wrong arch
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 5.7
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 5.7
Assignee: Greg Munn
URL:
Depends on:
Blocks:
 
Reported: 2014-12-15 17:31 UTC by Rustam Zaitov
Modified: 2014-12-18 11:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rustam Zaitov 2014-12-15 17:31:05 UTC
Migration tool will add 'ARM64' for every configuration. Migration tool should add ARM64 to:
* (Release|AddHoc|AppStore) iPhone

Note: Debug iPhone should be armv7 only. (Debug|Release) iPhoneSimulator should be i386 only

Migration tool will add ARM64 to simulator target if and only if <MtouchArch> node exists within PropertyGroup.

Steps to reproduce:
* Download ios7fonts sample from master branch (monotouch-samples repo) or any other classic sample
* Open csproj file and add <MtouchArch>i386</MtouchArch> to Debug|iPhoneSimulator PropertyGroup
* Run migration tool. Now Debug|iPhoneSimulator target will hold <MtouchArch>i386, ARM64</MtouchArch>

Or you can reproduce it in this way:
* Create new classic project with XS 5.7.0.652
* Make sure Debug|iPhoneSimulator holds <MtouchArch>i386</MtouchArch>
* Run migration tool.  Now Debug|iPhoneSimulator target will hold <MtouchArch>i386, ARM64</MtouchArch>
Comment 1 Rustam Zaitov 2014-12-15 17:33:21 UTC
The relative issue is here https://bugzilla.xamarin.com/show_bug.cgi?id=25005
Probably after fixing this 25005 will be fixed too.
Comment 2 Greg Munn 2014-12-15 22:21:03 UTC
Fixed in 5.7.0.656
Comment 3 Parmendra Kumar 2014-12-18 11:32:50 UTC
I have checked this issue and now its working fine.

Screencast:  http://www.screencast.com/t/5YMwS6Vl6

Environment info:

Xamarin Studio  5.7 (build 657)
Xcode 6.1 (6602)
Xamarin.iOS: 8.6.0.36 (Business Edition)
Mac OS X 10.9.4

Hence closing this issue.