Bug 25378 - Scrollview don't scroll SearchBar to top, if soft-keyboard appears
Summary: Scrollview don't scroll SearchBar to top, if soft-keyboard appears
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 1.3.0
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Chris King
: 24640 ()
Depends on:
Reported: 2014-12-15 06:11 UTC by Fredy Wenger
Modified: 2017-08-29 03:31 UTC (History)
13 users (show)

Tags: scrollview, searchbar, devicespecific, entry, android, ios, ac
Is this bug a regression?: ---
Last known good build:

See description (5.00 KB, text/plain)
2014-12-15 06:11 UTC, Fredy Wenger
soft keyboard does not scroll scrollview on Entry focus (164.35 KB, application/zip)
2016-07-23 10:34 UTC, adrianknight89

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report for Bug 25378 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:

Description Fredy Wenger 2014-12-15 06:11:19 UTC
Created attachment 9072 [details]
See description

Small example especially for rmarinho - forum-thread https://forums.xamarin.com/discussion/comment/92948?
Load page in attachment in iOS-device (iPhone5 / IPad), scroll down and click the last SearchBar.
The Keyboard appears, but you don't see the SearchBar (and your input).

I already have submitted the bug (including .pdf and whole real-live app) to bugzilla at 2014-11-19 
Link: https://bugzilla.xamarin.com/show_bug.cgi?id=24640

In the real-life-app, you can see, that the bug also exists on Android-Tablet (Samsung Tablet SM-T900).
Comment 1 Jatin 2014-12-16 03:57:38 UTC
I have tried to reproduce this issue at my end using the latest build, and I could successfully able to reproduce it. Below are the steps for the same:

1. Create a Blank Application (Xamarin.Form Protable)
2. Insert the code attached above in the project.
3. Debug the application on the iOS Device/Simulator
4. Observe the issue mentioned in the bug.

Supplement information:
Screencast: http://www.screencast.com/t/a3MVAGlF1OuU
IDE Logs: https://gist.github.com/Mohit-Kheterpal/e3fa1f891c1e391fc017
iOS Designer Logs: https://gist.github.com/Mohit-Kheterpal/f96baebd5e67f8844d59

Build information:

=== Xamarin Studio ===

Version 5.7 (build 652)
Installation UUID: 449f40dd-b3f1-4028-9a6b-cca0d1a2307d
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: (Trial Edition)
Hash: 13fc57b
Build date: 2014-12-10 16:07:02-0500

=== Xamarin.Android ===

Version: (Trial Edition)
Android SDK: /Users/360logicaxamarinmacmini/Desktop/android-sdk-macosx_AndÃsdk
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.Mac ===

Version: (Business Edition)

=== Build Information ===

Release ID: 507000652
Git revision: 042e44ba92a6a9c46bd2b69b0b4348df43f381ea
Build date: 2014-12-11 18:37:24-05
Xamarin addins: 06d3aaafde7f726d508e079c9b297cc9aae4af55

=== Operating System ===

Mac OS X 10.8.4
Darwin 360LogicasMacmini.local 12.4.0 Darwin Kernel Version 12.4.0
    Sun Mar 10 18:01:10 PDT 2013
    root:xnu-2050.24.6~1/RELEASE_X86_64 x86_64
Comment 2 Jatin 2014-12-16 03:59:17 UTC
*** Bug 24640 has been marked as a duplicate of this bug. ***
Comment 3 Fredy Wenger 2014-12-16 04:27:11 UTC
As I wrote, I have submitted the new bug-decription only on special request of rmarinho.
With my small example, I was NOT ABLE to see the bug also with my Android-tablet Samsung Tablet SM-T900).
With my earlier submitted bug 24640 you can also see, that this bug also exists on Android!
So this is only a "duplicate bug" if you also are able to comprehend the bug on Android. Else => investigate also my submitted full app!
Comment 4 Rui Marinho 2015-02-24 06:14:33 UTC
This should be fixed in 1.3.4 stable
Comment 5 Fredy Wenger 2015-02-24 06:33:05 UTC
You are right - this SHOULD BE fixed in 1.3.4 ;-)
BUT unfortunately, IT IS NOT FIXED everywhere finally:-(
Just tried 30 seconds ago...

On iOS (Phone and tablet): it seems to be is fixed. 
On Android Phone: it seems to be is fixed. 
On Android tablet: (Samsung SM-T900), it is NOT FIXED 

The bug STILL EXISTS on (at least my) Android-TABLET.
Comment 6 Fredy Wenger 2015-03-03 07:42:54 UTC
This bug still exists in 1.3.5 (final).
=> Tested on Android Tablet SM-T900
In the meantime, I have replaced the SearchBar with an Entry (same behavior)
Comment 7 Rui Marinho 2015-03-03 12:26:27 UTC
So the problem only happens on that device SM-T900 ?
Comment 8 Fredy Wenger 2015-03-03 12:37:15 UTC
Not sure...
I have tested it on a Chinese-Phone (compatible to Samsung GT-I9502) where it works and on SM-T900 where it DON'T works.
So.. maybe some Android-devices don't work or Android-tablet's don't work (I can't test it, as I only have this two devices ;-).
Comment 9 Fredy Wenger 2015-05-28 08:06:27 UTC
To help Xamarin by the clean-out of Bugzilla, I do a retest and review of all my filled bug's and set the bug to resolved myself, if I can't comprehend the bug anymore with the latest XF-Version.
This bug still exists with the Samsung SM-T900 tablet (where not on the other platforms and not on android-phones).
Comment 10 Guilherme Waltricke 2015-07-08 12:45:24 UTC
This bug still exists!!! tested in iPad Air + iPhone 4 and 6 if someone know how can i solve please tell.
Comment 11 Fredy Wenger 2015-07-08 13:11:26 UTC
@Guilherme Waltricke:

I have filled a new bug to Android some time ago (I have the Problem only on my Andorid-Tablet SM T900):

As the Problem seems to have a low priority (and I want to ship also my Android App -> b.t.w. shipped to Google Play about 20 Minutes ago), I have implemented a own workaround (that works for me with my Android-Tablet).
You can find it here:

I suggest you, to check it out (hopefully it may be also a workaround for you :-)
Comment 12 Bo Visfeldt 2016-07-05 11:41:56 UTC
We have the same bug.
Tested on iPhone 4S + Emulator,
Comment 13 adrianknight89 2016-07-23 10:31:53 UTC
I have this issue with an Entry:

   <StackLayout Orientation="Vertical" VerticalOptions="Center" HorizontalOptions="FillAndExpand">
     <Entry HeightRequest="50"></Entry>

Tested it on iOS 9 & XF

It's quite sad to see in two years this bug hasn't been fixed.
Comment 14 adrianknight89 2016-07-23 10:34:35 UTC
Created attachment 16770 [details]
soft keyboard does not scroll scrollview on Entry focus
Comment 15 Paul DiPietro [MSFT] 2017-05-15 19:52:35 UTC
*** Bug 56263 has been marked as a duplicate of this bug. ***
Comment 16 Mike Norman 2017-06-16 16:33:04 UTC
The repro case included has a requested height of 50, which failed to repro, but changing it to 500 caused it to repro again.