Bug 25369 - Bug reported when creating a new Xamarin.Forms project
Summary: Bug reported when creating a new Xamarin.Forms project
Status: RESOLVED DUPLICATE of bug 23210
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-12-14 13:17 UTC by Phil Morris
Modified: 2016-04-29 21:39 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Phil Morris 2014-12-14 13:17:25 UTC
Creation process reported the following with a request that it be reported...

Warning	1	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.FileNotFoundException: Could not load assembly 'HotspotScanner, Version=, Culture=neutral, PublicKeyToken=null'. Perhaps it doesn't exist in the Mono for Android profile?	HotspotScanner.Android
Comment 1 Jatin 2014-12-15 05:03:59 UTC

I have tried to reproduce this issue at my end. Below are the steps I followed:

1. Open VS
2. Created the forms template: Blank App (Xamarin.Forms Portable)
3. Observed that on creation it displays the warning (same as mentioned in the issue) and 8 errors
4. Set the android project as the start-up project and then build the application
5. Observed that the warning turns into error.

Here is the screencast for the same: http://www.screencast.com/t/TUHyin9oN

VS logs: https://gist.github.com/saurabh360/fb5f3078c3709f4f2e49
Build Output: https://gist.github.com/saurabh360/06dfe3af2a75bd57b760

Build information:
VS 2012 and 2013
Windows 7 - 32 bits
XVS 3.9.164

=== Xamarin Studio ===

Version 5.7 (build 652)
Installation UUID: 522f0c5e-80a3-4414-aec7-1f3b9c1768d1
	Microsoft .NET 4.0.30319.18408
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.26

=== Xamarin.Android ===

Version: 4.20.0 (Business Edition)
Android SDK: C:\Users\Admin\AppData\Local\Android\android-sdk
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
Java SDK: C:\Program Files\Java\jdk1.6.0_39
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04)
Java HotSpot(TM) Client VM (build 20.14-b01, mixed mode, sharing)

=== Build Information ===

Release ID: 507000652
Git revision: 042e44ba92a6a9c46bd2b69b0b4348df43f381ea
Build date: 2014-12-11 16:21:38-05
Xamarin addins: 06d3aaafde7f726d508e079c9b297cc9aae4af55

=== Operating System ===

Windows 6.1.7601.65536

Please confirm if this is the issue you were trying to report in the bug above.

And if this is not the issue you were trying to report, then it would be helpful, if you could please provide us with some more information such as:

1. Detailed steps to reproduce the issue
2. Video following the steps and getting the issue
3. VS logs (you can get the vs logs from Help >> Zip Xamarin Logs)
4. Build output
5. Build information

As of now marking this issue as Needinfo.
Comment 2 Phil Morris 2014-12-15 13:01:27 UTC
Your attempt to replicate the problem came up with additional errors not seen on my machine, but yes, the FileNotFoundException is the same.  However, when doing a build that warning disappears and no error regarding Android is reported.
Comment 3 Jatin 2014-12-16 00:17:15 UTC

I missed to update the Nuget Package and after doing the same, I am not getting the other errors. Only the warning mentioned in the bug above is appearing and when build the solution then that warning disappears and no error regarding Android is reported.

Below is the screencast for the same:

Hence, marking this issue as confirmed.
Comment 4 Phil Morris 2015-02-06 15:06:22 UTC
I still get this error on rare occasions but it does not prevent me from building or deploying Android apps.  Maybe it isn't a real error?
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2016-04-29 21:39:04 UTC
I will mark this as a duplicate of an older bug about this same _warning_.

Note that this message can also appear as an _error_. I have filed a separate bug about improving the wording of the _error_ in Bug 40782.

*** This bug has been marked as a duplicate of bug 23210 ***