Bug 25352 - SBElementArray is not bound
Summary: SBElementArray is not bound
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: Master
Hardware: PC Mac OS
: Normal normal
Target Milestone: 2.0.x
Assignee: Chris Hamons
Depends on:
Reported: 2014-12-12 15:27 UTC by Rob DeRosa
Modified: 2015-04-01 17:53 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Rob DeRosa 2014-12-12 15:27:11 UTC
Please bind SBElementArray for use w/ ScriptingBridges
Comment 1 Chris Hamons 2014-12-12 15:35:13 UTC
Nice to get in for 1.12 if we have time.
Comment 2 Chris Hamons 2014-12-18 15:30:03 UTC
Fixed in xamcore master / e9af558580a86c3185536773566fd2752b322d34.

See auto test for example or talk to me on use.
Comment 3 narayanp 2015-01-20 10:16:17 UTC
I have tried to verify this issue with latest XM but I am still not getting 'SBElementArray' with NSMutableArtray class.

Screencast: http://screencast.com/t/OhWVvujP

Hence I am reopening this issue.

Please let me know if I have missed any step to verify this issue.

Environment info:
=== Xamarin Studio ===

Version 5.7 (build 661)
Installation UUID: ff0c16c6-3c75-46d8-ac56-56c3b56e2c76
	Mono 3.12.0 ((detached/a813491)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000068

=== Apple Developer Tools ===

Xcode 6.2 (6758)
Build 6C107a

=== Xamarin.iOS ===

Version: (Trial Edition)
Hash: dfb682f
Build date: 2015-01-08 13:39:32-0500

=== Xamarin.Mac ===

Version: (Trial Edition)

=== Build Information ===

Release ID: 507000661
Git revision: b70bab61da996da29045ea8ee8aed1a6faedbe78
Build date: 2015-01-05 16:31:31-05
Xamarin addins: 82f6c71490562d6cd125a09287f441902fdac3d7

=== Operating System ===

Mac OS X 10.10.1
Darwin Apples-iMac.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 4 narayanp 2015-01-20 10:20:14 UTC
Correcting class name in comment 3,

NSMutableArtray => NSMutableArray
Comment 5 Timothy Risi 2015-01-20 18:54:55 UTC
This is fixed on master but doesn't look to have made it into 1.12, so moving to 2.0.x
Comment 6 narayanp 2015-03-03 13:30:32 UTC
I have checked this issue with latest master XM build and I am still obsessing same issue. I am still not getting 'SBElementArray' with NSMutableArray class.

Screencast: http://screencast.com/t/A34ZMGQn

=== Xamarin Studio ===

Version 6.0 (build 16)
Installation UUID: 91997f85-0008-4b4c-9f53-c7f991fcdae3
	Mono 3.12.0 ((detached/6235202)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 312000080

=== Apple Developer Tools ===

Xcode 6.2 (6770)
Build 6C121

=== Xamarin.Mac ===

Version: (Enterprise Edition)

=== Xamarin.iOS ===

Version: (Enterprise Edition)
Hash: 34c31b6
Build date: 2015-02-27 14:40:49-0500

=== Xamarin.Android ===

Version: (Enterprise Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 600000016
Git revision: 0b04780605a448f15691e250d6c0f7714f213001
Build date: 2015-03-03 11:37:32-05
Xamarin addins: 2a129a5faf33dc599db2e5fad0132f31e3a504dd

=== Operating System ===

Mac OS X 10.10.2
Darwin Apples-iMac.local 14.1.0 Darwin Kernel Version 14.1.0
    Mon Dec 22 23:10:38 PST 2014
    root:xnu-2782.10.72~2/RELEASE_X86_64 x86_64
Comment 7 Timothy Risi 2015-04-01 17:53:15 UTC
I just checked on a 2.0 build and SBElementArray exists, so moving this to milestone 2.0.x and marking resolved again