Bug 25130 - Error executing task CompileEntitlementsTask: Required property 'SdkVersion' not set.
Summary: Error executing task CompileEntitlementsTask: Required property 'SdkVersion' ...
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild ()
Version: master
Hardware: Macintosh Mac OS
: High major
Target Milestone: 8.6.0
Assignee: Jeffrey Stedfast
Depends on:
Reported: 2014-12-06 13:23 UTC by Gerry
Modified: 2015-01-21 08:30 UTC (History)
7 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Gerry 2014-12-06 13:23:56 UTC
So, after porting my iOS project to use the Unified API and fixing a bunch of errors I'm down to 1 final error that I can't seem to find anything on it:

Target _DetectSigningIdentity: /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing task DetectSigningIdentityTask: Required property 'AppManifest' not set. Build FAILED.
Comment 1 Jeffrey Stedfast 2014-12-08 09:00:57 UTC
Which version of Xamarin.iOS do you have installed? I don't think I've seen that bug in any of the released versions (although the released MSBuild targets have a number of kinks that I've worked out recently).

Try this: http://forums.xamarin.com/discussion/comment/88863/#Comment_88863

That should fix things. I've made a few more fixes since then (that will make it into 8.6.0), but they are pretty minor fixes.
Comment 2 Gerry 2014-12-08 09:45:41 UTC
I'm on the stable channel.

So X.iOS is
XS is 5.5.4

However, I saw the same bug on the alpha channel which has XS 5.6.3 (but no update for X.iOS).  So it sounds like the msbuild will fix this.  I will try them shortly.  So when is X.iOS 8.6 coming out?

Comment 3 Jeffrey Stedfast 2014-12-08 10:06:54 UTC
Should be coming out in January sometime (I think the plan is for early January)
Comment 4 Gerry 2014-12-08 10:09:49 UTC
Ok, I tried that and it compiled for the simulator (but failed at runtime but that's another issue).  But compiling for ad-hoc device build it fails with:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Error executing task CompileEntitlementsTask: Required property 'SdkVersion' not set.
Comment 5 Jeffrey Stedfast 2014-12-08 10:11:19 UTC
Okay, thanks. I'll look to see if this issue has been fixed in more recent updates.
Comment 6 Gerry 2014-12-08 17:26:04 UTC
Hi Jeff--I see the ticket is re-opened.  I'm going to assume I don't need to create another bugzilla on this for the SdkVersion issue.

Comment 7 Jeffrey Stedfast 2014-12-09 09:53:20 UTC
Correct. We'll just reuse this one.
Comment 8 Gerry 2014-12-10 16:25:45 UTC
I just got 8.6 from Alpha, now getting this error during build:

  Target _CompileToNative:
MTOUCHTASK: error MT2002: Failed to resolve "CoreGraphics.CGSize Foundation.NSString::StringSize(UIKit.UIFont,CoreGraphics.CGSize)" reference from "Xamarin.iOS, Version=, Culture=neutral, PublicKeyToken=84e04ff9cfb79065"
  Task "MTouchTask" execution -- FAILED

So still DOA.
Comment 9 Jeffrey Stedfast 2014-12-10 16:30:00 UTC
Okay, I've fixed this and uploaded a new https://files.xamarin.com/~jeff/iOS-MSBuildTargets.zip file
Comment 10 Jeffrey Stedfast 2014-12-10 16:30:45 UTC
The CGSize thing is unrelated to the MSBuild targets and should be submitted as a new bug so that the Xamarin.iOS devs can look into that.
Comment 11 Gerry 2014-12-10 17:57:22 UTC
Ok, I Just created a new bug for that one.


And I guess I have to open another bug as well--not sure if related--if I build for the simulator it compiles but then crashes when trying to open any NIB.

"Unhandled managed exception: Objective-C exception thrown.  Name: NSInternalInconsistencyException Reason: Could not load NIB in bundle..."
Comment 12 Leon 2014-12-11 04:46:46 UTC
The "Unhandled managed exception: Objective-C exception thrown.  Name:
NSInternalInconsistencyException Reason: Could not load NIB in bundle..." is because for some reason using the new build targets from the zip file do not add all the resources to the application bundle (this includes nib, image and plist files)
Comment 13 Jeffrey Stedfast 2014-12-11 08:41:07 UTC
Try cleaning your build and rebuilding.
Comment 14 Gerry 2014-12-11 09:01:04 UTC
I have many times.  I hit clean-all/build-all out of habit.
Comment 15 Jeffrey Stedfast 2014-12-11 09:15:04 UTC
The obj-c exception should probably have its own bug. If you could include a build log that would probably help me figure out the problem (although you might need to go to your Xamarin Studio Preferences and set your Build Log verbosity to "Diagnostic").
Comment 18 Mohit Kheterpal 2014-12-22 11:22:23 UTC
Still looking to connect with Jeffrey Stedfast to discuss to verifying this issue.
Comment 20 Jeffrey Stedfast 2015-01-07 12:34:45 UTC
Please provide a test case.
Comment 21 Gerry 2015-01-21 08:30:42 UTC
I opened a new bug since I just saw this on the release build with a new project.  I was able to simplify it down to a test case.