Bug 25008 - System.IO.IOException: Error creating standard output pipe
Summary: System.IO.IOException: Error creating standard output pipe
Status: RESOLVED DUPLICATE of bug 31604
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Activation ()
Version: 5.7
Hardware: Macintosh Mac OS
: High normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-12-02 15:18 UTC by Allie Miller
Modified: 2015-09-18 14:29 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE log (348.93 KB, application/octet-stream)
2014-12-02 15:18 UTC, Allie Miller
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 31604

Description Allie Miller 2014-12-02 15:18:22 UTC
Created attachment 8939 [details]
IDE log

Overview
   When opening Xamarin Studio on a Mac machine, users are met with an Unhandled Activation dialog. A snippet of the error is below:

   Error in license sync
   System.AggregateException: One or more errors occurred ---> System.IO.IOException: Error creating standard output pipe
  at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process)     [0x0019f] in /private/tmp/source-mono-mac-3.10.0-branch/bockbuild-mono-3.10.0-branch/profiles/mono-mac-xamarin/build-root/mono- 3.10.0/mcs/class/System/System.Diagnostics/Process.cs:1032 

Steps to reproduce
 This issue is intermittent, but the steps seem to be:
 1) Install the below listed version of the software.
 2) Login to Xamarin Studio using Xamarin Store Account credentials
 3) Close Xamarin Studio
 4) Open Xamarin Studio again and then build project

Expected results
  Project builds and Xamarin Studio does not present an activation dialog once logged in.

Actual results
  Users met with Activation Error

Additional Information
   I'll attach the ide logs with the full error to this report.
    The issue does not seem to appear when downgrading to the following versions of the software:
   Mono 3.8.0.13
   XS: 5.5.0.227
   XA: 4.18.0-32
   XI: 8.0.0.63
   Xcode: 6.1

   One other interesting (although maybe not related to issue) is that the About Xamarin Studio window sometimes appears completely blank. So far, this seems fixed as well with the downgrade.

Versioning Information where this is occurring:
    Mono: 3.10.0.31
    XS: 5.5.4.15
    XA: 4.20.0-28
    XI: 8.4.0.43
    Xcode: 6.1
Comment 1 Dave N 2014-12-03 09:15:23 UTC
I tried to resolve this issue on 2014-11-24, but had trouble with the re-install as noted:

I’m re-installing XS on the Mac. I kept getting an “Unhandled activation error” from Xamarin Studio. The error text seems to be referencing an issue with Mono 3.10.0. I ran the uninstall script from Xamarin, and manually made sure that all the target components were actually removed (they had not been). The installer indicated that Mono Framework and Java SDK installed, but reported an error while installing the Android SDK.
Comment 2 Dave N 2014-12-03 09:20:17 UTC
Regarding the behavior of the [About Xamarin Studio] dialog, I'm not seeing it appear as blank, but I have noticed that if the "Unhandled activation error" is displayed, that clicking on the [About Xamarin Studio] > [Show Details] does nothing (i.e. the dialog does not toggle to displaying the details).
Comment 3 Rajneesh Kumar 2015-07-10 10:23:24 UTC
I tried to reproduce this issue but not able to reproduce this. To reproduce this issue I  have followed the steps and instruction provide din bug description. I observed that I am able to build and deploy the application/project successfully without ant exception. Please refer the screencast:  http://www.screencast.com/t/KbjKJo11f 

Could you please check this issue with the latest build and let me know you are still getting this behaviour. 

Thanks..!

Build Output: https://gist.github.com/Rajneesh360Logica/69bb493b564d6318a799

Environment Info:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Xamarin.Android ===

Version: 5.1.4.16 (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.10.2.43 (Business Edition)
Hash: 428e4d4
Branch: master
Build date: 2015-07-03 10:41:01-0400

=== Xamarin.Mac ===

Version: 2.0.2.43 (Business Edition)

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 4 Greg Munn 2015-09-18 14:29:59 UTC
this looks like it is hitting the File Descriptor limit on Mac, similar issue to bug #31604

*** This bug has been marked as a duplicate of bug 31604 ***