Bug 24643 - WP: Picker dont show content
Summary: WP: Picker dont show content
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
Depends on:
Reported: 2014-11-19 04:53 UTC by Fredy Wenger
Modified: 2014-12-19 04:22 UTC (History)
4 users (show)

Is this bug a regression?: ---
Last known good build:

detail description (2.30 MB, application/pdf)
2014-11-19 04:53 UTC, Fredy Wenger

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Fredy Wenger 2014-11-19 04:53:51 UTC
Created attachment 8798 [details]
detail description

I have sent a mail with a dropbox download-link to bugzilla@xamarin.com at 11.18.
The name of the app is MatrixGuide.
I will now upload various bug-description's related to the app (you should be able to comprehend, if you install the app).
Each .pdf also contains a short description, how to serve the app and detailed information's to my SW-versions.
Comment 1 Sergio Paganoni 2014-12-18 11:27:00 UTC
I'm experiencing the exact same issue.
Picker doesn't show content anymore in WP.

I'm seeing the following exception when the Page loads:
{System.Runtime.Serialization.SerializationException: Expecting element 'ArrayOfKeyValueOfstringanyType' from namespace 'http://schemas.microsoft.com/2003/10/Serialization/Arrays'.. Encountered 'None'  with name '', namespace ''.

Not sure if they are related.

Since the bug is older then one month, can you at least confirm it?
Comment 2 Fredy Wenger 2014-12-18 11:32:49 UTC
@Sergio Paganoni:

Have you installed the latest Pre-3?  
I think this Problem is, solved...
My Picker shows now the content again (broken until Pre-2, solved in Pre-3)...

This for your information...
Comment 3 Sergio Paganoni 2014-12-19 04:02:51 UTC
Hi Fredy, thanks for the answer. Actually I was thinking I was using Pre-3 but was pre-2. Pre-3 fixed the issue, you may now close the bug.