Bug 24546 - User warned to install support lib v13 even though it is already installed
Summary: User warned to install support lib v13 even though it is already installed
Status: RESOLVED NORESPONSE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Greg Munn
URL:
Depends on:
Blocks:
 
Reported: 2014-11-14 16:17 UTC by Christopher Svanefalk
Modified: 2016-08-03 15:37 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Christopher Svanefalk 2014-11-14 16:17:33 UTC
Steps:

1. Start clean Android Application project
2. Install the support lib v13 from Components
3. In MainActivity.OnCreate, simply declare ViewPager pager;.

Results:

1. XS offers the user to resolve ViewPager to using Android.Support.V4.View.ViewPager only.
2. Accepting the above import lets the project build, but throws a warning that:

MainActivity.cs(4,4): Warning CS0618: `Android.Support.V4.View.ViewPager' is obsolete: `Please use the Xamarin Component: http://components.xamarin.com/view/xamandroidsupportv13-18' (CS0618) 

The component it asks the user to install is the same one as the one already having been installed.
Comment 1 Greg Munn 2014-11-17 11:50:37 UTC
Hey Christopher,  can you let me know what references you have in your project? 

I just tried this and it worked fine - ViewPager is in the Android.Support.V4.View namespace, and no warning. However, i notice that I do not have any other references to any other support libraries so just check that you do not have Android.Support.v4.dll as one of the references in your project.

Cheers.
Comment 2 Greg Munn 2015-01-08 10:32:32 UTC
Closing for now, please feel free to reopen if the problem recurs along with any additional information you have to help us resolve the issue.