Bug 24217 - Card.io Integeration
Summary: Card.io Integeration
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Alex Soto [MSFT]
Depends on:
Reported: 2014-11-03 00:23 UTC by Dinodroid
Modified: 2014-11-06 17:56 UTC (History)
2 users (show)

Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:

Description Dinodroid 2014-11-03 00:23:26 UTC
I'm creating IOS app using xamarin I integerated card.io in my app by adding card.io dll in references Its working fine while debugging If I moved to Adhoc or Appstore it will throw an native linking failed error MT5210.

Card.IO's guide states I need to add -lstdc++ to "other linker flags" in Xcode but I don't know where should I put this in Xamarin Studio's options.

Note: Its working fine in iOs 7.0 and above if I set deployment target as 6.0 it throws an error.

I need help for this.
Comment 1 Ram Chandra 2014-11-03 12:00:19 UTC
You can set the Xcode "other linker flags" in Xamarin by setting the "Additional mtouch arguments" field. 

You can find "Additional mtouch arguments" field from here : Right click on project => Property => iOS Build.

Screencast: http://www.screencast.com/t/1xpmsNBSxzll

If you still facing problem please attached sample project and Xamarin build information. 

You can fin build information from here:
Xamarin Studio=> About Xamarin Studio => Show Details => Copy Information.
Comment 2 Ram Chandra 2014-11-03 12:07:28 UTC
An update to the bug: 

Path of "Additional mtouch arguments" field : Right click on project => Property => iOS Build.
Comment 3 Dinodroid 2014-11-04 02:20:40 UTC
Hi Ram,

I tried that but its not working in iOS 6.0 here I have attached the my xamarin  build information.

I need your help to fix this.

=== Xamarin Studio ===

Version 5.1 (build 479)
Installation UUID: e3120e11-f0df-49d2-9b9b-4bf6f08c6485
 Mono 3.6.0 ((no/f540f8a)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 306000039

=== Apple Developer Tools ===

Xcode 5.0 (3332.25)
Build 5A1413

=== Xamarin.Mac ===


=== Xamarin.Android ===

Version: 4.12.5 (Business Edition)
Android SDK: /Users/admin/Library/Developer/Xamarin/android-sdk-macosx
 Supported Android versions:
  2.1   (API level 7)
  2.2   (API level 8)
  2.3   (API level 10)
  3.1   (API level 12)
  4.0.3 (API level 15)
  4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)

=== Xamarin.iOS ===

Version: (Business Edition)
Hash: 87026b6
Build date: 2014-07-02 19:39:08-0400

=== Build Information ===

Release ID: 501000479
Git revision: e5a428cec75d4cc7e6e3ccd8192a3660d013e7dc
Build date: 2014-06-26 09:28:17-04
Xamarin addins: 190d93e026e17280e75a3680ef38f2630b9228d3

=== Operating System ===

Mac OS X 10.8.4
Darwin MAC-HUSSAIN.local 12.4.0 Darwin Kernel Version 12.4.0
    Wed May  1 17:57:12 PDT 2013
    root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64
Comment 4 Dinodroid 2014-11-04 02:22:22 UTC
Hi Ram,

again that native linking failed its working fine in iOS7.0 but its not working in iOS6.0

I tried all that you mentioned in previous message. please help me to get sort this out.
Comment 5 Ram Chandra 2014-11-04 02:51:37 UTC
@Dinodroid: Thanks for the build information.

Could you please attach your sample project? So that I can reproduce this behavior at our end.
Comment 6 Alex Soto [MSFT] 2014-11-05 17:52:32 UTC
I can confirm the issue if you set the target to 6.0

Card.IO only supports 6.1 and up, still you get the errors if you target 6.1 will investigate more. It seems to be just a binding mistake.

Example of the errors:

 "std::__1::__vector_base_common<true>::__throw_length_error() const", referenced from:
      std::__1::vector<unsigned char*, std::__1::allocator<unsigned char*> >::__append(unsigned long) in libCardIO.a(libCardIO.a-armv7-master.o)
Comment 7 Alex Soto [MSFT] 2014-11-06 02:04:50 UTC
Yes, there was a binding mistake, I have fixed this and submitted a new component to the store version it should be live soon, will post here when it is live.

Thanks for reporting this @Dinodroid and thanks @Ram Chandra for helping on the resolution of this issue.

Comment 8 Alex Soto [MSFT] 2014-11-06 17:56:26 UTC
Component including fix is live at https://components.xamarin.com/view/cardioios version must be